ECU issue with the left side indicator bulb
2015 Ford Fiesta 1.2

Avatar
Daniel shahrezaey
Driver
1 points

Problem added: Oct 16, 2020 (6 months ago)
My car failed it’s MOT because of an ECU issue with the side repeater not working (nearside) the garage tried to get to the bottom of the issue but to no avail they think it could be either two things wrong with it (door lock issue or window mount problem) but the car locks and unlocks fine it shows no warning lights on the dashboard. This car is 5 years old. The indicator light doesn’t work on the left side door mirror so that’s why it failed the test.

Ford don’t know what the issue is either as well as the garage. I’ve been advised to speak to an auto electrician but they have said they can’t help if ford or the mot garage don’t know..

Help thanks

Car details
Car: Ford Fiesta
Variant: 1.2
Model Year: 2015
Category: Electrics, ECU, Warnings & Lights
Replies and Fixes
Avatar
whittingehame
Legend
18,655 points

Oct 16, 2020 (6 months ago) Edited on Oct 16, 2020 (6 months ago)
Check the bulb , if not that check wiring to lamp inside mirror and also the harness that passes through from the A post into the door .
Post a reply
Please login to reply.

Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Having a problem with your Ford Fiesta?

Tell us about your Fiesta problem

On Social Media