2004 Ford Fiesta 1.4 petrol Electric windows

Avatar
Adamerin
Fixes: 7
Problem added: May 15, 2020 (2 months ago)
Windows are not working both motors and regulators are good 12 volts in and out of the switch but when I operate the window switch the central locking clicks

Car details
Car: Ford Fiesta
Variant: 1.4 petrol
Model Year: 2004

Recalls: Ford Fiesta Recalls
More: Ford Fiesta Problems
Replies and fixes
Avatar
whittingehame
Fixes: 12,498
May 15, 2020 (2 months ago)
How do you know the motors / regulators are good ? Have you tested for power at motors ?
Avatar
Adamerin
Fixes: 7
May 15, 2020 (2 months ago)
Replying to post by whittingehame:
How do you know the motors / regulators are good ? Have you tested for power at motors ?
Yes straight supply to them and there was no problem when I put a meter on the motor supply lead and operate the switch I get 12 v but when I connect it to the motor and operate the switch it works the central locking cheers hope you can help
Avatar
whittingehame
Fixes: 12,498
May 15, 2020 (2 months ago)
What you could check for damage / breaks is the wiring in rubber sheath , where it passes through from A pillar to inside of door .
Avatar
Adamerin
Fixes: 7
May 15, 2020 (2 months ago)
Cheers will do
Avatar
Adamerin
Fixes: 7
May 16, 2020 (2 months ago)
Replying to post by Adamerin:
Cheers will do
Just tried another switch exactly the same stripped the door again to check the loom looks good baffling
Avatar
Adamerin
Fixes: 7
May 17, 2020 (2 months ago)
Do you know if you can change the bcm for a second hand one by simply unplugging mine and connecting the replacement
Avatar
Adamerin
Fixes: 7
May 17, 2020 (2 months ago)
Is it possible to just unplug and fit a second hand bcm unit
Avatar
whittingehame
Fixes: 12,498
May 17, 2020 (2 months ago)
If you are getting power at motor plug connections up and down when switch operated and ground / earth it must be a faulty motor . Replacing BCMs usually requires reprogramming .
Avatar
Adamerin
Fixes: 7
May 18, 2020 (2 months ago)
Took it to a auto electrician this morning and he sorted it turns out the multi plug on the a pillar required cleaning they have wax on them from the factory and this causes problems
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your Fiesta problem

Add your problem now, it's quick and easy

Post a Problem
News & Updates
Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

AutoInsider recall database updated
Recent recalls for Volvo, Audi and Porsche

Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media