Engine
2003 Ford Fiesta Zetec 1.6

Avatar
Lonestar
Driver
4 points

Problem added: Apr 27, 2009 (12 years ago)
I start the car which is fine the starter motor is fine. then almost immediately the engine gives out almost as though it has no petrol in it even though it has. Once its been running for 5 minutes its fine. I can stop the car turn it off and restart again with no problems its just the first 5 minutes while the engine is cold.Please help

Car details
Car: Ford Fiesta
Variant: Zetec 1.6
Model Year: 2003
Category: Engine & Drivetrain
Replies and Fixes
Avatar
mr suzuki
Top Fixer
694 points

Apr 28, 2009 (12 years ago)
iacv idle speed control valve the zetec has many different types on or under the inlet manifold.needs to be removed and cleaned with induction cleaner
Avatar
jake 1
Driver
37 points

Apr 29, 2009 (12 years ago)
Get the coolant temp switch checked as well as this could cause you similar problems.
Avatar
Lonestar
Driver
4 points

Apr 29, 2009 (12 years ago)
thank you
Avatar
Jason Casburn
Driver
1 points

Jul 5, 2009 (12 years ago)
my car is a 2005 Ford fiesta flame. 1.4... and i bought this from the show room about 6 weeks ago, the water pump went last week so had that repaird, then it wudnt turn over .. so i got a mahanice to have a look and i discoverd that their was 6 valves snapped.. what could of coursed this?? any tips?

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


AutoInsider AI Robot picture

You might find these links to parts and similar problems helpful in solving this problem.
AIBot

Having a problem with your Ford Fiesta?

Tell us about your Fiesta problem

On Social Media