Battery charge fault after new battery replacement
2001 Citroen Xsara Picasso 1.6i

Hello everyone,

My 2001 model Xpic had a total flat battery when car is not used in pandemic for 8 months.I tried jumpstart it but the engine was cutting off so I took it to a garage and they measured the battery and told me its dead. I replaced it with a new battery. The engine starts fine. But battery charge fault appears and AC is not working. Radio, lights, windows are working fine. I realized that when I rev the car the fault error disappears and AC starts to work. When I pull my foot off, battery fault alert appears again. Can it be an alternator problem? Or grounding problem?

Problem added: Jul 31, 2020 (1 year ago)
Avatar
Enis
1 points
Citroen Xsara Picasso (2001)
1.6i
Problem Category
Electrics, ECU, Warnings & Lights
Replies and Fixes
You will have to check the voltage of your new battery and alternator charging rate .Not the first time a new battery has been low or faulty so worth checking .
Replying to post by whittingehame:
You will have to check the voltage of your new battery and alternator charging rate .Not the first time a new battery has been low or faulty so worth checking .
Thanks. That is what I had in mind. Just wanted to get some opinions before going to an electrician. Thank you for the respond..

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.

Thinking about a DIY fix?

If it's a DIY fix and you need parts to do the job head over to Euro Car Parts.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Helpful & Related Pages on AutoInsider
Generated by AutoInsider AIBot
AutoInsider AI Robot picture
Having a problem with your Citroen Xsara Picasso?

Tell us about your Xsara Picasso problem

On Social Media