Charging fault after clutch change
2006 Citroen Xsara Picasso 1.6 petrol

Avatar
Tessy
Driver
3 points

Problem added: Jul 11, 2018 (3 years ago)
Hi all,
I've just replaced the clutch in a 2006 xsara Picasso 1.6 petrol and its developed a charging fault. The battery quickly discharges while the engine is running. I can charge the battery and it will stay charged all week as long as I don't run the engine.
I've checked all the earth cables that I removed and cleaned them just in case. There are no wires trapped that I can see. The battery warning light goes out as soon as the engine starts, but the voltage measured at the battery, or even at the alternator main terminal is below w 12volts.
I have substituted the alternator with h a known good unit and the problem persists.
Any ideas please anyone?

Car details
Car: Citroen Xsara Picasso
Variant: 1.6 petrol
Model Year: 2006
Category: Electrics, ECU, Warnings & Lights
Replies and Fixes
Avatar
1/4drive
Legend
1,892 points

Jul 11, 2018 (3 years ago)
Wiring fault,
Check at the underside of the fuse relay box and trace the wires back to the alternator.
Avatar
Subsonicnat
Driver
10 points

Apr 8, 2019 (2 years ago)
They have probably left the EARTH STRAP OFF GEARBOX.
COMMON PROBLEM..

This problem is archived

If you're having a similar problem please click below to re-post this problem, you can then customise it to suit your situation.


Options for fixing the problem

Fix the problem yourself

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Find a Local Mechanic

Use our AutoInsider Find A Specialist search, find garages and mobile mechanics near you.

Simply enter your postcode, select the required specialist areas and view your results.


Having a problem with your Citroen Xsara Picasso?

Tell us about your Xsara Picasso problem

On Social Media