2012 Citroen Berlingo 1.6hdi Electrical

Avatar
Seagull36
Fixes: 4
Problem added: Mar 19, 2017 (3 years ago)
My van every 3-4days horn goes off for 30seconds then beeps every 2mins, the battery light flashes and when I put the keys in the ignition it says "eco mode". The only way to stop the battery from draining it to disconnect the battery then re-connect it. Then it does it the process again 3-4days later. It's had a new battery and all equipment is switched off. I've done a battery drain test but only after re-connecting the battery. Citroen have taken the horn fuse out and no codes shown up on lexia (is that because I've bsi reset it?). Any suggestions are much appreciated before I pay for a new Bsi, comms2000, ecu etc.

Car details
Car: Citroen Berlingo
Variant: 1.6hdi
Model Year: 2012
Category: Electrics, ECU, Warnings & Lights

Recalls: Citroen Berlingo Recalls
More: Citroen Berlingo Problems
Parts mentioned in this problem
Replies and fixes
Avatar
1/4drive
Fixes: 1,862
Mar 20, 2017 (3 years ago)
There's a function on Lexia for taking it out of eco mode.
Surprised Citroen didn't try this.
Avatar
Seagull36
Fixes: 4
Mar 20, 2017 (3 years ago)
Yeah I wasn't that impressed with the effort/knowledge of the Citroen garage. If eco mode was switched off surely the battery would die, I'd rather not have a horn lol. It bucket'd down with rain last night and vans fine this morn so defo not a damp issue. Am I better off waiting till it does it again then getting it plugged up to lexia? Rather than disconnecting battery. It's like something under the bonnet won't shut off. The only fault code that came up and Citroen was for the comms2000 unit. They said they could change that at £400 but there was no guarantee it would fix it.
Avatar
paulieone
Fixes: 1,667
Mar 25, 2017 (3 years ago)
disconnect the connectors to the comm unit then reconnect.
When you say you have bsi reset it how did you do it?
Avatar
Seagull36
Fixes: 4
Mar 26, 2017 (3 years ago)
Have you had a look at this similar problem: Electrical

This message was auto-generated based on a user suggestion.
Avatar
Seagull36
Fixes: 4
Mar 26, 2017 (3 years ago)
Have you had a look at this similar problem: Electrical

This message was auto-generated based on a user suggestion.
Avatar
Seagull36
Fixes: 4
Mar 26, 2017 (3 years ago)
Have you had a look at this similar problem: Electrical

This message was auto-generated based on a user suggestion.
Avatar
moluki
Fixes: 5
Apr 1, 2018 (2 years ago)
Have you had a look at this similar problem:

This message was auto-generated based on a user suggestion.
Avatar
moluki
Fixes: 5
Apr 1, 2018 (2 years ago)
Hi! I opened the bonnet while it was raining, den later on the car didn't want to start and the wipers together with the lights went on ....the millage went blank....took it to the electrical they unable to start it....theys suspect coil park but I don't understand how could coil park affect millage ,the lights and the wipers....could it possibly b a computer box?
Avatar
whittingehame
Fixes: 12,485
Apr 1, 2018 (2 years ago)
Start a new post of your own instead of tagging on to old post . Suggest you get a garage that know what they are doing and can scan for faults .
Post a reply
Please login to reply
Planning on fixing the problem yourself?

If you need parts to do the job head over to Euro Car Parts to find the parts you need.

  • Free UK Delivery
  • 365 Day Returns
  • Free Click and Collect
Fix your Berlingo problem

Add your problem now, it's quick and easy

Post a Problem
News & Updates
Need an MOT after lockdown?
Find your nearest MOT Test Centre

Volvo Seat Belt Recall
Affects S60CC, V60CC, S60, XC60, V60, XC70, V70 and S80

AutoInsider recall database updated
Recent recalls for Volvo, Audi and Porsche

Find your nearest
Diagnostics App

Identify problem parts

Try it now
On Social Media