Vauxhall Insignia Engine & Drivetrain Problems

Engine & Drivetrain Problems and faults
7
responses
Engine juddering, spermatic start

After having issues with over heating, I paid for a new water tank. Car ran fine for a day, the next day it broke down 2. The garage couldn’t pick anything up on diagnostics and it ran again.

2016 Vauxhall Insignia Tourer
Posted: Jun 20, 2021
1
response
High rev, slow speed

Speed not commensurate with the rev. The more I press the accelrator, the more the rev goes up without speed. On the motor way, speed drops from 70 to like 30mph! Car also finds it difficult to go uph...

2011 Vauxhall Insignia 2.0 cdti
Posted: Jun 6, 2021
1
response
Insignia 2.cdti oil pump failure

see above oil pump failure

2010 Vauxhall Insignia 2.0 cdti
Posted: May 30, 2021
1
response
Aux belt keeps coming off after I’ve replaced both tensioners and belt

Replaced both tensioners and belt after it came off and it keeps running on the edge of the steering pump pulley , any ideas please ?

2008 Vauxhall Insignia 2.0 cdti
Posted: May 6, 2021
5
responses
Vauxhall insignia 09 1.8 engine rattle on start up or left for a bit

Rattle on start up or if left for a bit

2009 Vauxhall Insignia 1.8
Posted: Feb 14, 2021
2
responses
Automatic gearbox wont engage forward drive

automatic gearbox has no forward drive.drive sign on gearbox lever does not light up even in manual position .reverse,park and neutral lights all come on and seem to work.gear lever does go into drive...

2016 Vauxhall Insignia 1.6 automatic
Posted: Oct 21, 2020
9
responses
No drive, driveshaft fell out as a circlip was left off during manufacture

Whilst turning on full lock, I lost drive entirely. Had to call the AA, he found that the nearside driveshaft had fell out, so was put on a trailer and taken to the dealers. There it sat for 6 weeks a...

2016 Vauxhall Insignia 2.0 DTI grand tourer
Posted: Oct 4, 2020
2
responses
Service soon

Service soon won't clear dispite oil pressure sensor is fine and working

2014 Vauxhall Insignia ecoflex
Posted: Aug 14, 2020
0
responses
Eco not working

eco not working battery powered up full but still not working eco button lit up but engine not turning off ??

2014 Vauxhall Insignia 2.0 elite diesel
Posted: Jul 19, 2020
5
responses
P0268 injector 3 circuit high

When driving the car it vibrates and bad fuel consumption and usually when accelerating it goes into limp mode mostly on the motorway when going to overtake in fifth and 6th gear but sometimes in othe...

2011 Vauxhall Insignia 2.0 cdti
Posted: Jan 9, 2020
1
response
Blowing noise

Intermittent blowing noise from engine Already checked exhaust, flexipipe, replaced Cam sencer inlet & outlet any idea's please

2011 Vauxhall Insignia 2.o turbo petrol
Posted: May 20, 2018
7
responses
Vibration when accelerating

I have a 2015 insignia which vibrates when accelerating, usually around 2k rpm, this does not happen in the winter, only from March to October (15+degC), had new flywheel, driveshafts and fuel sensor ...

2015 Vauxhall Insignia VXR
Posted: Apr 6, 2018
2
responses
Revs

Revs fluctuating by 200 rev until we get to normal temp

2012 Vauxhall Insignia 2000ltr derv
Posted: Oct 19, 2017
1
response
Stop/start

The Eco button is permanently illuminated on my console showing that it is on, over the past few weeks it has stopped working, what could be causing this?

2000 Vauxhall Insignia 2.0 ecoflex
Posted: Feb 2, 2017
1
response
Engine Too Hot

My engine takes less than 5 minutes to go from stone cold to 90 degrees , is this normal ? I have had it checked out and every thing is as it should be, it doesn't go above that but I only use it to g...

2010 Vauxhall Insignia 2.0 CDTI SRI SAT NAV
Posted: Aug 7, 2016
1
response
Engine overheating

My car displays on deshboard stop engine is is overheated. Once i stop engine then it starts after long time but after driving long it appears again. Someone told me me it might b problem with therm...

2010 Vauxhall Insignia 2.00
Posted: Jul 1, 2016
1
response
Noise on engine

When u start from cold a get a ch ch ch noise from around alternator area

2011 Vauxhall Insignia 2.0 cdti sri
Posted: Jan 9, 2016
1
response
Engine rattle when starting up

Has anyone had a problem when starting the engine when it's warm? it starts fine when cold , however when the engine is warm and you start up, there's a rattle from the engine area. I'm not sure if...

2009 Vauxhall Insignia 2.0 D elite nav sports tourer
Posted: Dec 15, 2015
1
response
Cold start

Car tends to want to stall initiaaly when trying to pull away from a cold start. Dealership says this is normal, I don't buy this.

2009 Vauxhall Insignia 1.8 petrol manual elite
Posted: Nov 5, 2015
Having a problem with your Vauxhall Insignia?

Tell us about your Insignia problem

On Social Media