2004 Rover CityRover Problems

Problems and faults with the 2004 model year Rover CityRover
Search CityRover Problems

Select a CityRover Model Year
Latest 2004 Rover CityRover Problems
1
response
Is the 1400cc Rover City engine an interference engine

10,000 on the clock. No compression

2004 Rover CityRover 1400cc Rover City
Posted: Feb 20, 2021
1
response
Smell of petrol in car

My car has only done 25,000mls. I had a smell of petrol in when filling up and when turing right. I was told that the m...

2004 Rover CityRover Style 1.4
Posted: Sep 19, 2015
1
response
Strange 'chime' like sound emitted from beneath the dash in the region of the Passenger Airbag

Asked by a friend what was this seemingly random warning tone indicating? No dash warning lights illuminated. Can an...

2004 Rover CityRover 1.4 Petrol Manual
Posted: Nov 22, 2014
1
response
1
response
Car struggling to accelerate

When I change gear sometimes the car struggles to gain speed and sometimes slows down. Once stopped its fine and drives ...

2004 Rover CityRover Sprite
Posted: Jun 7, 2014
1
response
Power steering has stopped

the power steering has stopped working and the engine light has come on the dashboard

2004 Rover CityRover 1.4
Posted: Mar 2, 2014
1
response
Engine light on and cars cuttin off I put my foot down to rev up and I have to put it to the floor

Hi engine light on looks like a heart with valves. I start it buit seems there's no power goin through iv been told it s...

2004 Rover CityRover 1.4 manual
Posted: Jun 3, 2012
2
responses
Steering wheel/wheel squeaking

hey, i am just experiencing problems with my steering wheel and i really need help! it kept sqeuaking left and right whe...

2004 Rover CityRover 1.4
Posted: Feb 24, 2012
1
response
Gear stick shaking , srs light on, and petrol light on

Hi,just bought a CityRover, the Petrol light is on even after putting in about £15 worth,secondly The SRS light is on w...

2004 Rover CityRover 1.4
Posted: Feb 8, 2012
1
response
Heater not working

The heater on my car has just stopped working. Any ideas

2004 Rover CityRover 1.4
Posted: Oct 15, 2011
0
responses
Speedo not working

check speedo cable to speedo and needle is moving but there is a sensor on the gearbox that the speedo cable gos in to c...

2004 Rover CityRover
Posted: Jun 19, 2011
1
response
Near side lights blowing fuses

Ok hear goes, After standing idol for 6 months or so i took car for MOT, found out side lights on near side front, re...

2004 Rover CityRover 1.4 Sprite
Posted: Apr 17, 2011
1
response
Coilpack Failier

Fitted new coil, car ran perfect then the coil failed after 3-4 weeks. Replaced again and failed after 4 weeks. Replac...

2004 Rover CityRover
Posted: Feb 17, 2011
1
response
Over revving

when engine is switched on the rev counter will go up to between 1500 and 2000 revs on its own fluctuating between them ...

2004 Rover CityRover 1.4
Posted: Feb 2, 2011
2
responses
Headlights not working. Both High and low beam on both sides not working

Both High and low beam on both sides not working, fuses ok, Combi switch feels fine and digital clock dims when the head...

2004 Rover CityRover 1.4 petrol
Posted: Dec 11, 2010
1
response
Sensor

hi i replaced the cam sensor with a new one and it still comes up with the cam sensor fault,then i change the cam angle ...

2004 Rover CityRover 1.4
Posted: Nov 8, 2010
2
responses
Sensors

hi i've replaced the cambelt sensor with a brand new one and i'm still getting the same fault on the dianostic test any ...

2004 Rover CityRover 1.4
Posted: Nov 6, 2010
0
responses
Still missing

hi i've had all the car checked over and dio tested and i've now been told that its a electical problem between the two...

2004 Rover CityRover 1.4
Posted: Oct 29, 2010
2
responses
Heater

heater not working, blowing cold.

2004 Rover CityRover 1.4
Posted: Oct 11, 2010
3
responses
Still missing

hi i've replaced most of the parts with new ones the cambelt sensor, iginiton coil . spark plug leads and the fuel filte...

2004 Rover CityRover 1.4
Posted: Oct 7, 2010
Having a problem with your Rover CityRover?

Tell us about your CityRover problem