AutoInsider Logo

Peugeot 407 Light Bulbs faulty Warning messages

2004 Peugeot 407 Problem

The Problem:

Guys I have a problem with a 407 SW est that I bought last week. Firstly it showed a problem with the ABS & ESP. 208 later after having 2 X ABS Sensors fitted to the rear on Friday last, I now have the warning re faulty Indicators and L/H rear Stop light. When I press the Brakes I get the message re the Indicators and when I use the Indicators I get a message re the L/h rear stop light,Can you please expand a little on your fix. (On Sat both the ESP and ABS lights came on in the Dash, stayed on for the remainder of my journey, circa 10mins, did not come on when I restarted the Car and have not come on since. I wonder now did I need to spend the 208 at all)



Ref#7922
CarPeugeot 407 1.6 HDI SW Estate
Year2004
Ownerkevin75
Posted22/02/2011


More Peugeot and 407 problems


Solution 1

paulieone | Driver | Since: Aug 2009 | Posts: 4 | Fixes: 1211 | View Garage
Suggested Solution

there may be a fault with the connector to rear light units/ bulb holder.could also be a dodgy bulb


Posted on Thursday 24th of February 2011
Don't understand this? Ask a question

From Original Poster

kevin75 | Driver | Since: Aug 2010 | Posts: 0 | Fixes: 93 | View Garage
Suggested Solution

I found that the problem was the l/h rear brake / side light bulb was not inserted / twisted home fully. No further bulb warning messages since.




Posted on Sunday 27th of February 2011
Don't understand this? Ask a question

Suggestion

Ted FLemming | Driver | Since: May 2011 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

Have you had a look at this similar problem: Light Bulbs faulty Warning messages

This message was auto-generated based on a user suggestion.


Posted on Saturday 7th of May 2011

Solution 2

Ted FLemming | Driver | Since: May 2011 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

I have the same problem and have found that the Peugeot use a system of continuity to monitor the light bulbs and when the resistance gets to high it shows the light bulb as a failure. i have found by removing the light bulb cluster from the vehicle and then using a fine emery cloth clean each terminal on the light bulbs and then try and use the emery cloth on the contacts on the unit this may be a bit difficult as the holes are not made for sticking fingers in them.reinsert the light bulbs in the correct way and so far after six months i have not had any problems. The next time it tells me a bulb has gone when it has not i will proceed to perform my maintenance on it again unless the bulb really is gone. I also have a 2004 Peugeot 407 that i bought from new in August 2004.


Posted on Saturday 7th of May 2011
Don't understand this? Ask a question

Solution 3

najo | Driver | Since: Jun 2011 | Posts: 0 | Fixes: 6 | View Garage
Suggested Solution

The rear brake lights on my 407 stop working. I only get the rear windscreen brake light comming on when pressing down the pedal. I cleaned the terminal, changed the bulbs. I even changed the brake light switch, no change. Not been able to check the fuse becuase I am not quite sure which fuse is for the rear brake light on the 407. Soon as I turn on the car I get the message. "Right handside stop lamp fualty" & visa versa. Ocassionaly I get "ESP faulty" message as well.

Any advice on getting the above sorted would be appreciated



Posted on Thursday 2nd of June 2011
Don't understand this? Ask a question

Question

najo | Driver | Since: Jun 2011 | Posts: 0 | Fixes: 6 | View Garage
Suggested Solution

just replaced RH stop bulb on peugeot 407. My stop lamp bulbs tend to blow quite quicky becuase I always get a message " RH stop lamp bulb faulty". Any advice on what could be the cause for the stop lamps to keep blowing?


Posted on Friday 10th of June 2011
Know the answer to this? Post a solution

Solution 4

oldlimey | Driver | Since: Oct 2012 | Posts: 0 | Fixes: 3 | View Garage
Suggested Solution

Hello,

PEUGEOT 407 2004 2L.
Used to get the dashboard warning that an indicator bulb had gone when it had not, then whole rear left cluster stopped working. Took car to local auto electrical engineers (Curd Brothers Tunbridge Wells Kent)who diagnosed a corroded and/or burnt earth connection to the cluster which they very quickly fixed.


Posted on Monday 15th of October 2012
Don't understand this? Ask a question

Solution 5

oldlimey | Driver | Since: Oct 2012 | Posts: 0 | Fixes: 3 | View Garage
Suggested Solution

Further to my previous post there is a detailed DIY solution link:

http://www.scribd.com/doc/97546219/Peugeot-407-Rear-Bulbs-problem-fix


Posted on Thursday 18th of October 2012
Don't understand this? Ask a question


Ask a Question Post a Solution





Ads by Google


Twitter Icon Facebook Icon Google G+ Icon

Features

Car Problems