AutoInsider Logo Twitter Logo
[Logged Out] Log In | Sign Up
Home > Problems & Fixes > Vauxhall > Vauxhall Zafira

Vauxhall Zafira Fault codes

2006 Vauxhall Zafira Problem

AutoInsider Ref#: 7907
Use this number to refer to this problem
CarVauxhall Zafira 1.9 CDTI
Year2006
Ownerrossi_46
Posted21/02/2011


More Vauxhall and Zafira problems
The Problem:

Hi,
Over the last few weeks the performance of my zafira has deteriorated and the car with spanner light would come on after a few miles of driving and go into limp mode. If I turn the ignition off and then on again the light would go out. Now the light is on all the time and the car will start (but struggles), however it won't drive (No power there). I have done the pedal test and have got some codes. I have found an explanation of what they might be from the astra owners club website.
The codes are as follows in order they came up on the display:
1.7 003 02(or O2) (don't know what this means)
ECN
227911
190175
19010F (or OF)

I know to replace the ECN with a P and drop the last two numbers to obtain the code. The problem is; from the list below, how do I know what is what and does anyone know if these can be rectified by myself or is it a garge job?

P2279 Intake Air System Leak Detected B-03

P1901 Particulate Filter Pressure Sensor High Voltage C-032
P1901 Particulate Filter Pressure Sensor Low Voltage C-032
P1901 Particulate Filter Pressure Sensor Hose Line Malfunction B-031
P1901 Particulate Filter Pressure Sensor High Differential Pressure B-031
P1901 Particulate Filter Pressure Sensor Low Differential Pressure B-031
P1901 Particulate Filter Pressure Sensor Pressure not Plausible with Barometric Pressure B-031
P1901 Particulate Filter Pressure Sensor High Pressure C-032
P1901 Particulate Filter Pressure Sensor Low Pressure B-031

Many Thanks.






Solution 1


Suggested Solution

sounds like ecu problem need to take to dealer for tec 2 test





Posted on Sunday 27th of March 2011

Don't understand this?
Post a further question on this thread using this form Post a further question


Solution 2


Suggested Solution

sounds like ecu problem need to take to dealer for tec 2 test





Posted on Sunday 27th of March 2011

Don't understand this?
Post a further question on this thread using this form Post a further question




Ask a Question Post a Solution





Ads by Google