AutoInsider Logo

Ford Galaxy heater fan not working

2000 Ford Galaxy Problem

The Problem:

heter fan not working on 1st and 2nd speed, bu working fine on 3rd and 4th speed.

Ref#7756
CarFord Galaxy 2.3
Year2000
OwnerKEITH 9960
Posted10/02/2011


More Ford and Galaxy problems


Solution 1

2145simon | Driver | Since: Apr 2010 | Posts: 2 | Fixes: 1029 | View Garage
Suggested Solution

sounds like switch fault


Posted on Thursday 10th of February 2011
Don't understand this? Ask a question

Solution 2

whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 9175 | View Garage
Suggested Solution

Common fault usually is the series resistor (hedgehog)which is adjacent to the blower fan and behind the glove box .


Posted on Thursday 10th of February 2011
Don't understand this? Ask a question

Solution 3

2145simon | Driver | Since: Apr 2010 | Posts: 2 | Fixes: 1029 | View Garage
Suggested Solution

surely if it is the heater resistor then it will only work on top speed and nothing else


Posted on Thursday 10th of February 2011
Don't understand this? Ask a question

Solution 4

whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 9175 | View Garage
Suggested Solution

From Galaxy forum


Posted 23 April 2010 - 12:01 PM

QUOTE (Andy galaxy @ Apr 13 2010, 20:31:33)
just bought a galaxy heater blower switch only works on 3&4 is this mostlikely to be resistor.
also air con does not work at all carnt even hear any fan noise or pump runing is this case of recharge needed
or are they linked
many thanks



I had the same problem & it turned out to br the resistor. I tried my local scrappyard & they did not have one, so i searched the internet & found these guys that did cheap Ford Car Parts. Check them out they also deliver.




Posted on Thursday 10th of February 2011
Don't understand this? Ask a question


Ask a Question Post a Solution





Ads by Google


Twitter Icon Facebook Icon Google G+ Icon

Features

Car Problems