AutoInsider Logo
Logged Out | Log In | Sign Up


Home > Problems & Fixes > Mitsubishi > Mitsubishi L200

Mitsubishi L200 Starting problem

2008 Mitsubishi L200 Problem

Use this reference number to point people to this problem from other problem pagesAutoInsider Ref#: 6320
Use this number to refer to this problem
CarMitsubishi L200 2.5 DI-D
Year2008
Ownerakyhartless
Posted15/10/2010


More Mitsubishi and L200 problems
The Problem:

the problem is this, ther is no voltage for the glow's, but if i take the plug from the whater sensor ther is voltage for the glow's, so first i did, was replacind the water sensor, but stil, wont start at cold water,only if i take the plug from whater off, i have diag tool, but he can't see no problems, and the parameters are good, but stilhe will only give voltage to the glow's only if i take the plug off from the water sensor.
i thing the ECU is entering some king of injury state, and thats why he gives voltage to the glow's.
So ill be greatefull for some advices




Ads by Google






Solution 1


Suggested Solution

Glow plug relay ? IF it's a 2008 is it not still under warranty ?





Posted on Friday 15th of October 2010

Don't understand this?
Post a further question on this thread using this form Post a further question




Post a solution Post a solution





Sponsored Links



DISCLAIMER
Please note that the comments made here and the suggested solutions are the opinions of the posting user and should not be taken as professional advice. If in any doubt please seek professional advice from your local specialist. Find mechanics in your area using our Auto Local Directory.