AutoInsider Logo

Citroen C3 lumpy idle disappears above 2k revs.

2005 Citroen C3 Problem

The Problem:

Car starts fine but idles lumpy both when cold or hot.above 2k revs evens out.Drives fine nippy and smooth and responsive.Good mpg.Never hesitates or stalls and runs clean.Passed mot with no comments.
Any ideas folks!
GRAHAM.

Ref#5867
CarCitroen C3 1.4 hdi 8v
Year2005
OwnerGRAHAM SIMS
Posted01/09/2010


More Citroen and C3 problems


Solution 1

2145simon | Driver | Since: Apr 2010 | Posts: 2 | Fixes: 1029 | View Garage
Suggested Solution

could be an injector or pump fault,get a diagnostic run to check fault codes and sensor readings


Posted on Wednesday 1st of September 2010
Don't understand this? Ask a question

Solution 2

whittingehame | Legend | Since: Oct 2009 | Posts: 443 | Fixes: 9002 | View Garage
Suggested Solution

Could check this re. water / corrosion getting to injector from washer jet.


C3 Misfire
27 February 2010, 6:52 PM bigtony
Joined 12 Jan 2005
852 posts


hi. ive done quite a few of these. cylinder 4 is the cylinder nearest to the timing belt, (french, backwards) you will prob find the injector connector is corroded up. most times the corrosion has got into the injector and a new one is required. the other fault codes you have could be to do with the missfire. but a suspect coil pack sounds more like it. Ive come across this b4 too on these.sorry of this post is a bit late for you .
--------------------------------------------------------------------------------
Discussion Archived

--------------------------------------------------------------------------------

C3 Misfire
3 March 2010, 0:55 AM ian
Joined 16 Sep 2006
930 posts


water drips from the drivers washer jet onto the injector causing the corrosion as tony said. there is a mod kit for the washer jet. its a rubber seal and a washer but a bit silicone around the base of the jet works just as well.

Hope this helps you .


Posted on Wednesday 1st of September 2010
Don't understand this? Ask a question

Solution 3

paulieone | Driver | Since: Aug 2009 | Posts: 4 | Fixes: 1211 | View Garage
Suggested Solution

being a 1.4 hdi i wouldnt have thought it had a coil pack.May have an egr fault


Posted on Friday 3rd of September 2010
Don't understand this? Ask a question

Solution 4

vinny kane | Driver | Since: Mar 2011 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

After reading various reviews on my motherinlaws citreon c3, with the problem of lumpy running and cutting out at junctions, I was shocked at the thought of replacing injectors at the cost of 300 plus. I decided to try an injector cleaner, being Pro Tec Fuel Line Cleaner. The salesman advised me to put this in with no more than a quarter of a tank of fuel and then to run the car as much as possible. Now, 5 days on and after refuelling, this appears to have rectified the problem. I feel this is worth a try before going on to a greater cost solution.


Posted on Monday 7th of March 2011
Don't understand this? Ask a question


Ask a Question Post a Solution





Ads by Google


Twitter Icon Facebook Icon Google G+ Icon

Features

Car Problems