AutoInsider Logo Twitter Logo
[Logged Out] Log In | Sign Up
Home > Problems & Fixes > Renault > Renault Megane

Renault Megane High Revs when ticking over

2005 Renault Megane Problem

AutoInsider Ref#: 10472
Use this number to refer to this problem
CarRenault Megane 1.4 16v
Year2005
Owneradwozere
Posted18/10/2011


More Renault and Megane problems
The Problem:

This started a few days back when driving home,when the car is ticking over the Revs go up to from about 1000 to anything upto 3000. !!
Cant even see where the cable is to see if its sticking, it all seems to be at the back of the engine near the bulk head.
Ive also checked all the vaccum pipes I can see and they look ok along with all the air intake pipes.

Any help would be great





Solution 1


Suggested Solution

You dont have a cable , that's why you cant find it . Check / clean idle air control valve / throttle body .





Posted on Tuesday 18th of October 2011

Don't understand this?
Post a further question on this thread using this form Post a further question


From Original Poster



Thanks for coming back to me.
I can find the throttle body and it looks a massive job get off as there dont seem to be any room to get to it, is there an easy way to do it?
and I cant seem to find the idle air control valve.
As to the cable lol wondered why could not find it hehehe, sorry for being so thick never realy worked on renaults much before






Posted on Tuesday 18th of October 2011

Don't understand this?
Post a further question on this thread using this form Post a further question


Solution 2


Suggested Solution

Just noticed the year of your car , probably not got an IAC valve .Try cleaning the throttle body in position with carb cleaner / throttle body spray .You may have to try reset throttle adaptation/ throttle reset precedure .





Posted on Tuesday 18th of October 2011

Don't understand this?
Post a further question on this thread using this form Post a further question


From Original Poster



Thanks I will give the carb cleaner ago 1st





Posted on Tuesday 18th of October 2011

Don't understand this?
Post a further question on this thread using this form Post a further question


From Original Poster



Tried the carb cleaner today and didnt help at all :-(
ticks over ok at 1st but when you drive it revs go between 1500 and 2500 when your at a stand still.
any ideas any one?






Posted on Sunday 23rd of October 2011

Don't understand this?
Post a further question on this thread using this form Post a further question


Solution 3


Suggested Solution

check your engine oil level, when i add some engine oil the hi revs was gone





Posted on Sunday 23rd of October 2011

Don't understand this?
Post a further question on this thread using this form Post a further question


From Original Poster



Thats all ok as it only had a full service about 6 weeks ago





Posted on Monday 31st of October 2011

Don't understand this?
Post a further question on this thread using this form Post a further question




Ask a Question Post a Solution





Ads by Google