AutoInsider Logo

Citroen C4 Brake lights

2007 Citroen C4 Problem

The Problem:

I have replace new brake light switch but wont work. Third stoplamp is working. I had replace both new bulbs at back brake lights and fuses is ok. I need your help what others way the problem? thanks!

Ref#10133
CarCitroen C4 1.6 HDI
Year2007
OwnerHelloKitty
Posted14/09/2011


More Citroen and C4 problems


Solution 1

whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 9057 | View Garage
Suggested Solution

Is this the same post as below ?


If the centre brake light is working , switch must be o.k .Check you have the correct bulbs fitted i.e whether single or double contact . Test for power supply at bulbs / holder .


Posted on Wednesday 14th of September 2011
Don't understand this? Ask a question

From Original Poster

HelloKitty | Driver | Since: Sep 2011 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

I put both new bulb is type P21W. Is this correct? As same as Reverse bulb? When the reverse, there is two lights as bottom and middle bulbs are same, no brake lights. Is it the same bulbs asreverse and brake lights? Any ideas?


Posted on Wednesday 14th of September 2011
Don't understand this? Ask a question

From Original Poster

HelloKitty | Driver | Since: Sep 2011 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

Can you explain me what this single or double contact? Test for power supply at bulbs / holder. thanks


Posted on Wednesday 14th of September 2011
Don't understand this? Ask a question

Solution 2

whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 9057 | View Garage
Suggested Solution

Not sure on that car , reverse light will be single contact .On a lot of cars the brake light is double contact and works tail light also , but dont know on your car . Look at bulb you removed and see if it has two contacts on base .


Posted on Wednesday 14th of September 2011
Don't understand this? Ask a question

From Original Poster

HelloKitty | Driver | Since: Sep 2011 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

Reverse is single as well Brake light. not double. I look at instruction. I dont find where the problem with both no brake lights on when all working especially third stoplamp in middle. My car is c4 grand picasso. any clue to suggest?


Posted on Wednesday 14th of September 2011
Don't understand this? Ask a question

Solution 3

delboy_11 | Driver | Since: Sep 2011 | Posts: 0 | Fixes: 60 | View Garage
Suggested Solution

check contact on buld holder for corrosion or dirty contact. use a multi metter or test lamp and place it onto the connection inside the bulb holder to check if you have power going to it when brake pedal is pressed.


Posted on Wednesday 14th of September 2011
Don't understand this? Ask a question

Suggestion

royston | Driver | Since: Nov 2011 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

Have you had a look at this similar problem: Brake lights

This message was auto-generated based on a user suggestion.


Posted on Wednesday 30th of November 2011

Question

Paul79 | Driver | Since: Oct 2012 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

Hi, did you get this resolved? I seem to have the same problem and have no idea where to go next. If you did, what was the problem?



Posted on Tuesday 9th of October 2012
Know the answer to this? Post a solution

Solution 4

Ghost | Driver | Since: Jan 2014 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

hi

I have a 2008 C4 picasso lounge and have the same problem.
The contacts are good with no corrosion. I have replaced the 2 rear brake bulbs but they wont come on.

Any ideas?

thanks

Mike


Posted on Saturday 18th of January 2014
Don't understand this? Ask a question


Ask a Question Post a Solution





Ads by Google


Twitter Icon Facebook Icon Google G+ Icon

Features

Car Problems