Fiat Stilo airbag failure

2003 Fiat Stilo Problem

Ref#7965
CarFiat Stilo 1.2
Year2003
Ownerumar
Posted25/02/2011
Ads by Google
if someone is sitting on the front passenger side and if you switch on the ignition it indicates "airbag failure" but sometimes it doesn't ! maybe its some sensor problem ! iv cleaned out the airbag connectors but still no luck ! iv looked up sensors for the stilo its about 100 euros !!!!!!! 11 any suggestions ?
Problem Category
Electrics, ECU, Warnings & Lights

Running Rough, Starting & Power Loss


Solution 1
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11974 | View Garage
Suggested Solution

Checked connections under seat ?


Posted on Saturday 26th of February 2011
Don't understand this? Ask a question
Solution 2
polynikes | Driver | Since: Jul 2011 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

I have airbag failure on the dashboard all the time! where are the connections under 'the seat'? could it just be a fuse?


Posted on Sunday 3rd of July 2011
Don't understand this? Ask a question
Solution 3
dai | Driver | Since: Oct 2011 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

i had the same problem with my car under passenger side seat there are cables when you out seat forward to get in the back cables have a loose conection check if any are loose once i seen it toke 10 mins to repair hope this helps


Posted on Saturday 22nd of October 2011
Don't understand this? Ask a question
Ask a Question Post a Solution


More Fiat and Stilo problems

Fiat Problems Stilo Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?