AutoInsider Logo

Vauxhall Astra goes into limp mode

2003 Vauxhall Astra Problem

HI.CAN ANYONE HELP WITH THIS PROB.
ASTRA CDTI 1.7 2003. THE CAR RUNS FINE AND PULLS WELL BUT WHEN ON MOTORWAY DOING LETS SAY 70MPH IF I TRY TO ACCELERATE THE ENGINE WARNING LIGHT COMES ON AND IT GOES INTO LIMP MODE. SOON AS IVE TURNED OFF IT CLEARS AND IS FINE UNTIL IAM BACK ON THE MOTORWAY IN THE SAME SITUATION. ITS SEEMS ALSO THAT IT SEEMS TO HAPPEN MORE IF IAM GOING SLIGHTLY UP HILL PUTTING THE ENGINE UNDER MORE STRAIN. BUT AT SLOW SPEEDS AROUND TOWN ITS FLIES NO PROBLEM. IVE HAD THE FAULT CODE CHECKED AND IT COMES UP AS TURBO BOOST SENSOR BUT IAM WONDERING IF THE EGR CAN GO FAULTY CONFUSING THE SENSOR. IF IT IS THE SENSOR DOES ANYONE KNOW WHERE ITS SITUATED ON THE ENGINE???
Ref#7500
CarVauxhall Astra cdti 1.7
Year2003
Ownercourier1961
Posted23/01/2011
Ads by Google
Problem Category
Engine, Cooling System & Drivetrain

Electrics, ECU, Warnings & Lights

Running Rough, Starting & Power Loss


Solution 1
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 9892 | View Garage
Suggested Solution

There you go , this should help you ,

http://www.astraownersclub.com/vb/showthread.php?t=179386


Ps. How about putting the caps lock off when you post ?


Posted on Sunday 23rd of January 2011
Don't understand this? Ask a question
From Original Poster
courier1961 | Driver | Since: Jan 2011 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

ok thanks very much for that.
ps..the caps lock button has jammed on keyboard thus the capitals...but thanks for the advice


Posted on Tuesday 25th of January 2011
Don't understand this? Ask a question
Ask a Question Post a Solution


More Vauxhall and Astra problems

Vauxhall Problems Astra Problems

More from Auto Insider

Twitter Icon Facebook Icon Google G+ Icon

Car Problems

Can you use a spanner?
Run an Auto Business?