Fiat Stilo losing water

2002 Fiat Stilo Problem

Ref#5327
CarFiat Stilo 1.6 active
Year2002
Ownerscott3477
Posted06/07/2010
Ads by Google
IVE NOTICED THAT IM LOSING WATER.I ONLY DO 30 MILES A WEEK ON AVERAGE IN THE CAR BUT NEED TO FILL UP EVERY 10 DAYS OR SO.CHECKED THE OIL AND CANT SEE NO CONTAMINATION ANY IDEAS?
Problem Category
Engine, Cooling System & Drivetrain


Solution 1
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11976 | View Garage
Suggested Solution

If you can't see where you are losing water from , a pressure test will show any external leaks and a sniff test ( block test ) will tell you if head gasket leaking .It all depends where head gasket leaks whether you get oil / water mixing or not .If cooling system not pressurising , could be something minor .


Posted on Tuesday 6th of July 2010
Don't understand this? Ask a question
Solution 2
andrew slevin | Driver | Since: Jun 2010 | Posts: 0 | Fixes: 163 | View Garage
Suggested Solution

could be something simple like a radiator leak. check around area for a leak and pipes to radiator. if radiator is leaking get a bottle of rad weld or something that will seal leak.


Posted on Tuesday 6th of July 2010
Don't understand this? Ask a question
Similar Problem Suggestion
vincent | Driver | Since: Jul 2010 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

Have you had a look at this similar problem:

This message was auto-generated based on a user suggestion.


Posted on Tuesday 6th of July 2010
Similar Problem Suggestion
vincent | Driver | Since: Jul 2010 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

Have you had a look at this similar problem: Dents in rear panel

This message was auto-generated based on a user suggestion.


Posted on Tuesday 6th of July 2010
From Original Poster
scott3477 | Driver | Since: Jun 2009 | Posts: 0 | Fixes: 2 | View Garage
Suggested Solution

ive checked it again this morning,i havent lost any water but have noticed the expansion bottle is really hot after a 2 mile drive,could this tell you anything further ?


Posted on Wednesday 7th of July 2010
Don't understand this? Ask a question
Solution 3
andrew slevin | Driver | Since: Jun 2010 | Posts: 0 | Fixes: 163 | View Garage
Suggested Solution

hi maybe a coolant temperature sencer fault. have you checked radiator for leaks??


Posted on Wednesday 7th of July 2010
Don't understand this? Ask a question
Ask a Question Post a Solution


More Fiat and Stilo problems

Fiat Problems Stilo Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?