Mini Cooper Speedo below zero

2002 Mini Cooper Problem

Ref#21142
CarMini Cooper
Year2002
Ownerrichard7467
Posted06/10/2018
Ads by Google
Hi All

I have a small but potentially troublesome problem
When stationary tbe needle on my Mini is below zero actually sits in the 6 oclock position but does respond ie moves up as I accelerate im probably doing around 30mph before it fets to zero??
All help much appriciated
Problem Category
Electrics, ECU, Warnings & Lights


Solution 1
1/4drive | Auto Insider | Since: Jun 2011 | Posts: 25 | Fixes: 1845 | View Garage
Suggested Solution

Potentially a faulty speedo head unit fault.


Posted on Saturday 6th of October 2018
Don't understand this? Ask a question
Solution 2
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11829 | View Garage
Suggested Solution

Used to be the o/s/r ABS sensor that was also the speed sensor that gave problems .Could the wiring / dirt at sensor but may be module fault . Really need to get it scanned with proper diagnostic equipment that can read the ABS also to find fault for definite .


Posted on Saturday 6th of October 2018
Don't understand this? Ask a question
From Original Poster
richard7467 | Driver | Since: Oct 2018 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

ok thanks I will update once scanned


Posted on Sunday 7th of October 2018
Don't understand this? Ask a question
Solution 3
Cmg | Driver | Since: Oct 2018 | Posts: 0 | Fixes: 5 | View Garage
Suggested Solution

Check earth block/wires around the nearside front headlamp area. Had problems with corrosion.


Posted on Saturday 13th of October 2018
Don't understand this? Ask a question
Ask a Question Post a Solution


More Mini and Cooper problems

Mini Problems Cooper Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?