Citroen Xsara Picasso Won't idle, no power.

2007 Citroen Xsara Picasso Problem

Ref#20598
CarCitroen Xsara Picasso
Year2007
Ownerjami74
Posted08/09/2017
Ads by Google
Car starts but cuts out immediately, needs lots of revs just to keep it idling.

Drove home from work (20 miles) and the car was fine, there was nothing unusual about the journey. I stopped at my office for about twenty minutes, when I restarted the car it cut out (a bit like when it is hot in the summer and the ac is on), so I restarted again and gave it a bit more revs to keep it going. It was a 3 mile drive home with a little bit of traffic. Cut out at the traffic lights half a mile from home and needed a lot of revs after that to limp the rest of the way.

There were/are no warning lights on the dashboard. Has had a recent service and MOT (last month). Put £20 of petrol in 3 days ago and have done about 80 miles since then, still two bars showing. It doesn't feel like dirty petrol (have had that experience previously).

I'm fearing the worst, but is there any chance that it could be something simple?
Problem Category
Engine, Cooling System & Drivetrain

Running Rough, Starting & Power Loss


Solution 1
Derbyshire | Driver | Since: Sep 2015 | Posts: 0 | Fixes: 176 | View Garage
Suggested Solution

You could try replacing the coolant sensor.


Posted on Friday 8th of September 2017
Don't understand this? Ask a question
From Original Poster
jami74 | Driver | Since: Sep 2017 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

You think it could be that? There were no signs of overheating or smoke. The temperature gauge was still at the bottom where it usually is? Hope it is that though, sounds like it would be cheaper than a new engine. :)


Posted on Friday 8th of September 2017
Don't understand this? Ask a question
Solution 2
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11441 | View Garage
Suggested Solution

Most likely to be the idle air control valve needing cleaned or replaced .Other common possible cause could be the coil pack but usually triggers the EML .When were the plugs last checked or replaced ?


Posted on Friday 8th of September 2017
Don't understand this? Ask a question
From Original Poster
jami74 | Driver | Since: Sep 2017 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

It had an interim service last month and a full service 13 months ago, so I'm guessing the spark plugs were done 13 months ago.


Posted on Friday 8th of September 2017
Don't understand this? Ask a question
Solution 3
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11441 | View Garage
Suggested Solution

If the plugs were changed it should show on itemised parts on invoice. Badly worn plugs can adversely affect engine performance .


Posted on Friday 8th of September 2017
Don't understand this? Ask a question
From Original Poster
jami74 | Driver | Since: Sep 2017 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

Thank-you. Hope it's just the plugs, you've reassured me it might not be a write-off. I'll get it towed to the garage and see what they say.


Posted on Saturday 9th of September 2017
Don't understand this? Ask a question
Solution 4
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11441 | View Garage
Suggested Solution

It's more likely to be a combination , possibly plugs / coil pack / idle air control but nothing too expensive if those .Of course it's really hard to be definitive in diagnosing from here as there are so many possibilities but hopefully nothing serious .If you need further help , get back to the forum .


Posted on Saturday 9th of September 2017
Don't understand this? Ask a question
Ask a Question Post a Solution


More Citroen and Xsara Picasso problems

Citroen Problems Xsara Picasso Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?