Ford Mondeo Vibration

2007 Ford Mondeo Problem

Ref#20594
CarFord Mondeo 1.8d Duratec model
Year2007
Owneraot
Posted04/09/2017
Ads by Google
Hi all, have this Mondeo but very bad vibrations between 1300 rpm and 200 rpm at idling and when moving. Heavy vibration underfoot which gets very uncomfortable driving around, have replaced 3 out of the 4 fuel injectors but made no difference, it's a 10 year old car so don't want to spend too much any ideas?
It also vibrates a lot at speed-(120km +), I have replaced all tyres with new ones but still vibrates badly?
Appreciate any help before spending more !
Problem Category
Running Rough, Starting & Power Loss


Solution 1
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11441 | View Garage
Suggested Solution

Check engine mountings , check wheel balance .


Posted on Monday 4th of September 2017
Don't understand this? Ask a question
Solution 2
1/4drive | Auto Insider | Since: Jun 2011 | Posts: 25 | Fixes: 1513 | View Garage
Suggested Solution

Possible dual mass flywheel fault.


Posted on Monday 4th of September 2017
Don't understand this? Ask a question
Solution 3
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11441 | View Garage
Suggested Solution

You have it as a 1.8d Duratec , all Duratec engines are petrol . Is yours a petrol or diesel ? If it does have a DMF , that will probably be your cause of vibration .


Posted on Monday 4th of September 2017
Don't understand this? Ask a question
From Original Poster
aot | Driver | Since: Sep 2017 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

Thank you both for that. its a diesel engine with 111k miles on it, I was hoping it wasn't the dmf, I guess I'll have to get a mechanic to look at that. I'm also not sure if the fuel injectors were synced right, the engine can splutter at times and loses power for a second or two- my investigations
thanks again
aot


Posted on Monday 4th of September 2017
Don't understand this? Ask a question
Similar Problem Suggestion
Crawf | Driver | Since: Sep 2017 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

Have you had a look at this similar problem:

This message was auto-generated based on a user suggestion.


Posted on Monday 11th of September 2017
Ask a Question Post a Solution


More Ford and Mondeo problems

Ford Problems Mondeo Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?