Citroen Xsara Picasso backfiring

2005 Citroen Xsara Picasso Problem

Ref#20538
CarCitroen Xsara Picasso 1.6 twin cam petrol
Year2005
Ownerlyron
Posted01/08/2017
Ads by Google
been told this could be due to an air leak on the intake manifold. how difficult is it to change said gaskets. or could there be another reason for it.

ron.
Problem Category
Engine, Cooling System & Drivetrain


Solution 1
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11463 | View Garage
Suggested Solution

Could also be caused by timing being out .


Posted on Tuesday 1st of August 2017
Don't understand this? Ask a question
Solution 2
1/4drive | Auto Insider | Since: Jun 2011 | Posts: 25 | Fixes: 1538 | View Garage
Suggested Solution

Or the exhaust manifold!
when leaking it draws fresh air in and the hot exhaust gasses detonate it.
Or excess carbon build up in the combustion chamber.
There's quite a few possible causes.
I'd start with a smoke test of the induction system.


Posted on Wednesday 2nd of August 2017
Don't understand this? Ask a question
From Original Poster
lyron | Driver | Since: Jul 2017 | Posts: 0 | Fixes: 4 | View Garage
Suggested Solution

many thanks for the quick response. new timing belt recently fitted but will re- check


Posted on Wednesday 2nd of August 2017
Don't understand this? Ask a question
Solution 3
1/4drive | Auto Insider | Since: Jun 2011 | Posts: 25 | Fixes: 1538 | View Garage
Suggested Solution

Get an exhaust gas check done at your local MOT station and post the results.


Posted on Wednesday 2nd of August 2017
Don't understand this? Ask a question
From Original Poster
lyron | Driver | Since: Jul 2017 | Posts: 0 | Fixes: 4 | View Garage
Suggested Solution

problem now solved. according to the service history ( so called)quick fit auto services did the servicing on it for the past three years. during that time they had done work on intake manifold and exhaust front pipe ,so that rang alarm bells. removed intake manifold .NO GASKETS!!!! just sealant. two 10 mm nuts missing so sorted that mess out and then went to exhaust front pipe / manifold. two studs snapped . so thoroughly enjoyed sorting that out .runs fine now. many thanks for the very sound advice,,,,,ron.


Posted on Thursday 3rd of August 2017
Don't understand this? Ask a question
Ask a Question Post a Solution


More Citroen and Xsara Picasso problems

Citroen Problems Xsara Picasso Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?