Toyota Aygo refs goes up and down

2013 Toyota Aygo Problem

Ref#20057
CarToyota Aygo 1,5 toyota avanza
Year2013
Ownerjones 32
Posted28/11/2016
Ads by Google
when car is idling refs goes up and down between 1000 and 2000. battery was replaced by agents , but it is still problem
Problem Category
Electrics, ECU, Warnings & Lights


Solution 1
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11367 | View Garage
Suggested Solution

Check for any vacuum / breather hose leaks and inlet manifold ..Check engine oil cap is fitted correctly

P.s It's revs not refs


Posted on Monday 28th of November 2016
Don't understand this? Ask a question
Solution 2
1/4drive | Auto Insider | Since: Jun 2011 | Posts: 25 | Fixes: 1448 | View Garage
Suggested Solution

Some vehicles need a throttle body reset after a battery change.
if not done then you get your symptoms.


Posted on Tuesday 29th of November 2016
Don't understand this? Ask a question
Solution 3
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11367 | View Garage
Suggested Solution

^ good reply . Sometimes driving for a while , stop starting can reset .
This is from elsewhere on same subject ,

" Disconnecting the battery has caused the engine ECU to loose its learnt values including throttle body idle control calibration, disconnect the battery again, reconnect it and switch on the ignition but do not start, leave the ignition on for at least 5 minutes then start the car this should allow the ECU to relearn the throttle body calibrations, "


Posted on Tuesday 29th of November 2016
Don't understand this? Ask a question
Ask a Question Post a Solution


More Toyota and Aygo problems

Toyota Problems Aygo Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?