Vauxhall Astra Strange symptoms, is this an ECU fault?

2015 Vauxhall Astra Problem

Ref#19907
CarVauxhall Astra 1.6 CDTI SRI
Year2015
OwnerPhotoplanet
Posted12/09/2016
Ads by Google
On my Diesel Astra (110PS, 97g/km EcoFlex), I have recently noticed a strange 'fault'. Since the first main dealer service (20,000 miles and 1 year since new) I have noticed an occasional slight juddering in power delivery, usually when on the speed limiter or cruise control, at the same time, the fuel consumption display drops noticeably (could be from 50 down to 20 ish mpg), and on the screen showing electrical consumption items, the rear screen demist icon is displayed, despite this item not being selected or in use.

The ECU warning light never comes on during this fault period, and there is no obvious cause. Nothing I can do apart from turning the ignition off and back on seems to cancel the fault, which goes away after several minutes on its own.

No pattern to the occurrence, but usually after several miles, and not associated with startup.

I plan to take the car back to the dealer, but any ideas, based on the symptoms? Would an ECU update have been done as part of a dealer service?
Problem Category
Electrics, ECU, Warnings & Lights

Running Rough, Starting & Power Loss


Solution 1
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11463 | View Garage
Suggested Solution

Any updates relating to your car should have been carried out automatically by dealership on servicing .Worth asking if any applied or were installed . Leave it up to them to solve under warranty .Usually find those on service reception nowadays haven't a clue and better not suggesting anything as they will be none the wiser .


Posted on Monday 12th of September 2016
Don't understand this? Ask a question
Similar Problem Suggestion
HUSSAIN.AH3 | Driver | Since: Sep 2016 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

Have you had a look at this similar problem:

This message was auto-generated based on a user suggestion.


Posted on Tuesday 13th of September 2016
Similar Problem Suggestion
Ianbean | Driver | Since: Oct 2016 | Posts: 0 | Fixes: 0 | View Garage
Suggested Solution

Have you had a look at this similar problem:

This message was auto-generated based on a user suggestion.


Posted on Saturday 1st of October 2016
Ask a Question Post a Solution


More Vauxhall and Astra problems

Vauxhall Problems Astra Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?