Skoda Octavia Ventiltation works fine at low speeds but doesn't work at high speeds

2007 Skoda Octavia Problem

Ref#17127
CarSkoda Octavia Estate Ambiente 1.9tdi
Year2007
OwnerStumpski
Posted15/09/2014
Ads by Google
The fans and climate control works fine at low speeds but after about 20min of 70mph+ speeds air stops coming out of the vents. The fans are still working but the air is blocked somehow, even if the car is back travelling at lows speeds again, only when it has been turned off & has cooled down will the ventilation work properly again.
An independent garage has failed to find the problem. Any ideas?
Problem Category
Engine, Cooling System & Drivetrain

Leaks & Noises, Interior and Bodywork


Solution 1
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11462 | View Garage
Suggested Solution

Pollen / cabin filter needing replaced .


Posted on Monday 15th of September 2014
Don't understand this? Ask a question
From Original Poster
Stumpski | Driver | Since: Sep 2014 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

Pollen filter has been replaced


Posted on Tuesday 16th of September 2014
Don't understand this? Ask a question
Solution 2
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11462 | View Garage
Suggested Solution

Better to get a proper fault code scan (Vagcom)carried out , rather than guessing / replacing parts at random


Posted on Tuesday 16th of September 2014
Don't understand this? Ask a question
Ask a Question Post a Solution


More Skoda and Octavia problems

Skoda Problems Octavia Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?