Ford Mondeo Fuel Problems, loss of power & engine Stop

2001 Ford Mondeo Problem

Hi, My problem is a fuel one, the car will start, sometimes tick over then cuts out, sometimes can travel bit of a way then vuts out. When it cuts out the diesel heater light starts flashing.

I use bio fuel (chip fat), have used for couple of years no probs, changed fuel filter. The car has been stood virtually still since November.

Could the chip fat have blocked and set in the fuel filter, or is it something else.
CarFord Mondeo 2lt Diesel zetec
OwnerDean Lennox
Ads by Google
Problem Category
Engine, Cooling System & Drivetrain

Electrics, ECU, Warnings & Lights

Leaks & Noises, Interior and Bodywork

Running Rough, Starting & Power Loss

Solution 1
mr mondeo | Driver | Since: Nov 2008 | Posts: 0 | Fixes: 42 | View Garage
Suggested Solution

yes the chip fat could be to thick try proper fuel for your car not chip fat it is not built fot it and you have to filter the chip fat first.

Posted on Wednesday 25th of February 2009
Don't understand this? Ask a question
Solution 2
mastertech | Driver | Since: Oct 2008 | Posts: 0 | Fixes: 221 | View Garage
Suggested Solution

hi the actuall problem is the cam position sensor their is a rework which is a sensor and new plug . i work for ford and do aprox 2 a week 100% fault fix

Posted on Wednesday 25th of February 2009
Don't understand this? Ask a question
paul eck | Driver | Since: Mar 2009 | Posts: 0 | Fixes: 2 | View Garage
Suggested Solution

i've got a 2004 mondeo 2 ltr tdci as i drive i get loss of power ,heater plug light flashes then sometimes cuts out also ticks over really bad ,been told off fords high pressure fuel pump u/s 2.500 to repair

Posted on Sunday 8th of March 2009
Know the answer to this? Post a solution
Solution 3
hiren | Driver | Since: Jun 2009 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

dear mastertech

we change fuel pump,cam sensor,plug,map sensor ,ignition coil ..but the problem is same my running car stop and when i off the key and on it again it work fine .i already change all above parts of another working condition mondeo but strange result found that good condition mondeo have same problem so now i have 2 with same problem.

please reply as possible as soon



Posted on Thursday 4th of June 2009
Don't understand this? Ask a question
Ask a Question Post a Solution

More Ford and Mondeo problems

Ford Problems Mondeo Problems

The Latest

Car Problems

Run an Auto Business?
Twitter Icon Facebook Icon Google G+ Icon