Ford Fiesta no lights on dash except oil light

2003 Ford Fiesta Problem

Ref#13859
CarFord Fiesta Finesee 1.4 semi auto
Year2003
Ownerzimbo
Posted15/11/2012
Ads by Google
Greetings again,and thank you to Steve who tried to help.This is an update to my previous post.Checked every fuse in the box,replaced the relays.All electrics work except cluster main lights.In the dark you can see just four green boxes for a second when you switch on.Ford say no codes.Usually starts up after a few days,and goes without fault.This time it appears terminal. Any ideas will be welcome.
Problem Category
Engine, Cooling System & Drivetrain

Electrics, ECU, Warnings & Lights


Solution 1
bustedknuckles | Driver | Since: Nov 2011 | Posts: 2 | Fixes: 1461 | View Garage
Suggested Solution

I would first check for power at the plug to your cluster this will tell you if it,s a power feed issue or the cluster .then follow the wiring to the next junction connection and carry out continuity test on each power wire to ensure no breaks .you will require a wiring diagram to fault trace this.If this vehicle is networked it could be something else that is bringing the network down a wiring diagram would tell you this also.If it is running a network there could be a short which is bringing down the power level .I do not want to go too in depth .as like I say the correct model year diagram will tell you and just try following the wiring to source firstly.


Posted on Thursday 15th of November 2012
Don't understand this? Ask a question
Ask a Question Post a Solution


More Ford and Fiesta problems

Ford Problems Fiesta Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?