Chrysler Grand Voyager chyrsler grand voyager acclaration

2005 Chrysler Grand Voyager Problem

Ref#12871
CarChrysler Grand Voyager
Year2005
Ownerpaul burr
Posted01/06/2012
Ads by Google
"HI
I have a 2005 Chrysler grand voyager crd xs ltd engine size 3301 which has done 71,000 miles in march I had the car converted to lpg gas so it is now dual fuel petrol and gas. I started having trouble with the car in April when a engine warning light come on it showed the cam shaft sensor and when i tried to accelerate and revved the car over 3 the car would shudder and lose power. I got the garage to replace the cam shaft sensor and the car was fine for two weeks and then the engine warning light came on again showing the error as the oxygen sensors I also had the same problem with acceleration. The garage replaced the oxygen sensors and the engine warning light showed the error the camshaft sensors the garage the took the gear box out and inspected it and changed the timing belt but the car is still the same he is now asking me to get a starter ring gear as there maybe a slight crack in casing which he cannot see. The Garage is not trying a fast one as he has not charged me as he has not resolved the problem but i think he is running out of ideas I have also noticed recently that the engine is getting very hot. the only other thing that is wrong with the car is the automatic sliding door on the passenger side not working. I hope you can give me some advise"
Problem Category
Gearbox & Clutch

Electrics, ECU, Warnings & Lights

Running Rough, Starting & Power Loss


We currently have no solutions for this problem.

Do you know what the problem is?

If so please log in and post, go on you know you want to!

Not a member? sign up here it's free and easy.


Ask a Question Post a Solution


More Chrysler and Grand Voyager problems

Chrysler Problems Grand Voyager Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?