Vauxhall Astra idle speed drops off and engine cuts out when slowing down

2003 Vauxhall Astra Problem

Ref#11324
CarVauxhall Astra 1.6 8 valve 5 door hatch back
Year2003
Ownerphilccrk
Posted28/12/2011
Ads by Google
when slowing my tick over drops off and the engine cuts out. It will start straight up on the key but its very frustrating any ideas please
Problem Category
Running Rough, Starting & Power Loss


Solution 1
whittingehame | Legend | Since: Oct 2009 | Posts: 444 | Fixes: 11924 | View Garage
Suggested Solution

Check /clean/ or replace IACV ( idle air control valve )


Posted on Wednesday 28th of December 2011
Don't understand this? Ask a question
Solution 2
Ian the drummer | Driver | Since: Jan 2012 | Posts: 0 | Fixes: 1 | View Garage
Suggested Solution

Hi, right then... Sounds like we both have the same problem..
Does the car seem to kangaroo shortly before it cuts out by any chance? I've been trying to find a fix for this for over a year now.
Try unplugging the rear lambda sensor (mounted on top of exhaust, post cat) this cured my problem completely apart from the EML being on permanently. I've tried changing both sensors, cleaned and re-built throttle body, changed coil pack, plugs and changed the air intake temp sensor and replaced the EGR valve, all of which were suggested as possible culprits for the problem. This basically leaves a faulty cat.... Mine passed emissions on mot with no problem... Am now having probs with fuel gauge not reading correctly too so hoping this may be part of the problem.
Hope we can get to the bottom of this!!


Posted on Tuesday 3rd of January 2012
Don't understand this? Ask a question
Ask a Question Post a Solution


More Vauxhall and Astra problems

Vauxhall Problems Astra Problems

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?