AutoInsider Logo Twitter Logo
[Logged Out] Log In | Sign Up
Home > Car Problems > Ford > Fiesta Problems and Repairs

Ford Fiesta Problems and Repairs

Listing of owners' problems with the Ford Fiesta

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem


Page
1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 |

2
replies
Clutch/gear issues
2003 1.6 Zetec
Thursday 7th of August 2014


1
reply
Sychronmesh problem how much will it cost to get it fixed
2003 1.6man
Friday 27th of June 2014


1
reply
Gear box problem
2003 1.6 man
Friday 27th of June 2014


1
reply
Idfling/pick up
2001 1.3i endura e engine petrol
Sunday 22nd of June 2014



3
replies
Gearbox noise
2009 1.25 zetec
Tuesday 29th of April 2014


1
reply
Cutting out when slowing down
2008 1.4 Zetec
Wednesday 23rd of April 2014


1
reply
Battery removal
2006 1.25
Thursday 3rd of April 2014


4
replies
Clutch wear!
2004 1.4 Zetec
Wednesday 26th of March 2014


1
reply
Wont start
1997 Chicane
Wednesday 26th of February 2014


4
replies
Wont start due to emergency stop. then stalling
1997 Chicane
Wednesday 26th of February 2014


1
reply
Kicking fan
2012 1.4 diesel manual
Saturday 15th of February 2014


2
replies
Reverse gear jumps out
2012 I,25
Saturday 8th of February 2014


4
replies
Grinding noise
2002 Finess
Friday 10th of January 2014


4
replies
Water in spark plug casing
2003 1.3 manual
Wednesday 8th of January 2014


1
reply
ABS light, hand brake light and engine warning lights all on
2005
Tuesday 31st of December 2013


2
replies
Starting/running
2001 1.3 manual
Friday 27th of December 2013


3
replies
Car starts and cuts out after 2-5seconds
2001 1.3 finesse
Friday 27th of December 2013


6
replies
Electric Windows not working
2005 1.4 Zetec Climate
Monday 16th of December 2013


3
replies
Blower Fuse keeps blowing on my Fiesta
1989 Mkiii LX
Monday 9th of December 2013


3
replies
Over revving after changing up gears
2002 Freestyle 1.25 Zetec SE
Monday 25th of November 2013



9
replies
Knocking sound from rear right side
2056 Style climate 1.25
Saturday 9th of November 2013


1
reply
Noise from front on slw movement
2002 1.4 lx tdci
Monday 4th of November 2013


4
replies
Noise from front on slw movement
2002 1.4 lx tdci
Monday 4th of November 2013


1
reply
cant drive off revs to low
2007 Manual
Monday 28th of October 2013


4
replies
Engine revs when throtle not touched
1999 1.25 16v manual
Tuesday 1st of October 2013


1
reply
Handbrake not working
1999 1.25 ztec manual
Sunday 22nd of September 2013


4
replies
Water in spark plugs
2003 1.3 manual
Friday 20th of September 2013


1
reply
Climate control blower.
2010 1.4 zetec
Sunday 15th of September 2013


2
replies
Cam bely broke
2004 13cdti
Sunday 15th of September 2013


1
reply
Coil pack
1999 1.25
Friday 16th of August 2013


2
replies
Coolant fan stays on
2008 1.6 TDCi
Wednesday 7th of August 2013


3
replies
Electronics / battery problem
2010
Monday 15th of July 2013


4
replies
Need some advice please
2007 1.25 Style Climate
Wednesday 10th of July 2013



4
replies
Judder on gear change
2011 1.6 tdci titanium
Sunday 2nd of June 2013


1
reply
Light appears in dsh board
2011 1.4
Monday 20th of May 2013


1
reply
Boot will not open
2004 1.4 Flame
Friday 10th of May 2013


1
reply
Alarm
2009 1.4 petrol titanium
Sunday 7th of April 2013


1
reply
Turns over, but won't start!!!
2000 1.8 turbo diesel
Friday 29th of March 2013


3
replies
Can't accelerate when cold and power loss at 60 mph
1996 1.2
Wednesday 27th of March 2013


1
reply
Overheating problem
2000 1.6 zetec s
Monday 18th of March 2013


3
replies
Overheating problem
2000 1.6 zetec s
Monday 18th of March 2013


11
replies
Will not rev
2006 1.4 TDCi Van
Thursday 7th of March 2013


2
replies
Dashboard Light
2004 TransitConnect
Saturday 2nd of March 2013


2
replies
CD Autochanger?
2006 1.25 style
Wednesday 20th of February 2013


1
reply
Fuel gauge not showing accurate reading
2001 1.3 flight
Monday 18th of February 2013


4
replies
Power train warning lamp
2008 1560cc zetec climate TDCI manual 5speed
Friday 15th of February 2013


3
replies
Boot switch doesn't work
1996 Ghia Auto
Friday 8th of February 2013


Page
1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 |



Sponsored Links



Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem