Ford Focus Problems - Page 9

List of owners' problems with the Ford Focus

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest Focus Problems

3
replies
Missing part of spark plug
Wednesday 21st of July 2010

4
replies
Steering wheel makes rubbing noise
Tuesday 20th of July 2010


2
replies
Creaking when turning at low speed
Monday 19th of July 2010

3
replies
Warning lights, speedo, rev and temp droping
Tuesday 13th of July 2010

7
replies
Miss fireing from number 2
Tuesday 13th of July 2010

2
replies
High Acceleration whilst driving...
Friday 9th of July 2010

1
reply
Misfiring
Tuesday 6th of July 2010

2
replies
Coil pack and ht leads ohms
Sunday 4th of July 2010

2
replies
Alarm
Saturday 3rd of July 2010


1
reply
Juddering
Wednesday 30th of June 2010

6
replies
Ignition coil
Tuesday 29th of June 2010

1
reply
Remote sensor
Monday 28th of June 2010



2
replies
Air bag light coming up on dash
Saturday 19th of June 2010

5
replies
When to change timing belt on ford focus
Friday 18th of June 2010

5
replies
Water in spark plugs
Monday 14th of June 2010


7
replies
Loss of power and high fuel consumation
Thursday 10th of June 2010

2
replies
Vibration noise when in motion
Sunday 30th of May 2010

2
replies
Temp gauge
Saturday 29th of May 2010

3
replies
Turbo
Monday 24th of May 2010

1
reply
Fan not working
Sunday 16th of May 2010

1
reply
Heater blower not working tryed the fuses
Sunday 16th of May 2010

1
reply
Hairline crack in block
Sunday 16th of May 2010

1
reply
Gears
Thursday 13th of May 2010

1
reply
Display panel
Tuesday 11th of May 2010





2
replies
Engine system fault
Thursday 29th of April 2010

1
reply
Tyre road noise
Tuesday 27th of April 2010

1
reply
Engine managment light
Monday 26th of April 2010

3
replies
Smoke
Friday 16th of April 2010

1
reply
Ignition
Thursday 8th of April 2010

5
replies
Cant Get over 60mph
Sunday 4th of April 2010

3
replies
Coolant loss
Sunday 4th of April 2010

2
replies
Engine
Thursday 1st of April 2010

3
replies
High revvs then losing power then cuttin out
Thursday 1st of April 2010

1
reply
Car wont go over 50mph
Wednesday 31st of March 2010

2
replies
Temp gauge and management light
Sunday 28th of March 2010

2
replies
Temp gauge and engine management light
Sunday 28th of March 2010


2
replies
Poor mpg
Saturday 27th of March 2010

1
reply
Accelerator stuck
Wednesday 24th of March 2010

1
reply
Losing power of accelarator
Saturday 20th of March 2010


1
reply
Water
Monday 1st of March 2010




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?