Ford Fiesta Problems - Page 9

List of owners' problems with the Ford Fiesta

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest Fiesta Problems


1
reply
STIFF GETTING INTO GEAR
Wednesday 20th of January 2010


4
replies
Car wont exceed 4000 rpm
Wednesday 20th of January 2010

1
reply
Lack of power on motorway
Saturday 9th of January 2010

2
replies
Heater not working properly
Thursday 7th of January 2010

1
reply
Hazard warning lights not working correctly
Thursday 7th of January 2010

1
reply
Water leaking in to the drivers footwall
Sunday 3rd of January 2010

2
replies
Central locking only works on the passenger side
Wednesday 30th of December 2009

1
reply
Central locking not working
Wednesday 30th of December 2009



1
reply
Intermittent problem changing gear
Wednesday 23rd of December 2009

1
reply
Stiff gears
Tuesday 15th of December 2009



2
replies
Code for radio
Sunday 6th of December 2009

1
reply
Rain water getting into driver side footwell
Friday 4th of December 2009

2
replies
No power in the gears
Thursday 3rd of December 2009

2
replies
Nearside rear break pipe leaking
Friday 27th of November 2009

3
replies
IMMOBILISER LIGHT
Thursday 26th of November 2009


3
replies
Please help car keeps cutting out!!
Sunday 22nd of November 2009

2
replies
Heater always cold
Thursday 12th of November 2009

1
reply
Tempreture spiking and loss of power
Thursday 12th of November 2009

2
replies
Ford Fiesta Clutch Pedal
Sunday 8th of November 2009

1
reply
Ford Fiesta Clutch Pedal
Sunday 8th of November 2009

2
replies
Temp gauge
Wednesday 4th of November 2009

1
reply
Brake light in booy lid not working
Thursday 29th of October 2009

1
reply
Car not working at all
Monday 26th of October 2009

1
reply
Vibration and loss of power
Wednesday 14th of October 2009

0
replies
Irratic idling on cold start
Thursday 1st of October 2009

1
reply
Intermittent Overheating
Sunday 27th of September 2009

0
replies
Hunting, revs high and mis firing?
Monday 21st of September 2009

4
replies
Over flow oil
Monday 21st of September 2009

2
replies
Intermitant fault
Friday 18th of September 2009

3
replies
Car not starting well, and idles poor sumtimes stall
Sunday 13th of September 2009

1
reply
Both brake lights not working.
Thursday 3rd of September 2009

1
reply
Automatic self locking system not working
Thursday 3rd of September 2009

0
replies
Ticking noise
Sunday 30th of August 2009

1
reply
Intermittent power loss
Saturday 29th of August 2009

1
reply
Chugging and stalling in an automatic.
Saturday 22nd of August 2009

1
reply
Strange engine smell and car shaking
Thursday 20th of August 2009

1
reply
Intermittent chugging
Friday 7th of August 2009

1
reply
Not Starting?
Tuesday 4th of August 2009

2
replies
Starting
Tuesday 4th of August 2009

1
reply
Brakes won't bleed
Saturday 1st of August 2009


1
reply
Wishbone bushes
Wednesday 22nd of July 2009

2
replies
Radio code
Sunday 12th of July 2009

2
replies
Heater fault
Saturday 11th of July 2009




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?