Ford Fiesta Problems - Page 6

List of owners' problems with the Ford Fiesta

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest Fiesta Problems

2
replies
Car lacks poer when cold
Saturday 27th of August 2011

1
reply
Buzzing Noise?
Thursday 18th of August 2011


1
reply
Dashboard Light stays on.
Friday 12th of August 2011

1
reply
Air Conditioning Unit
Thursday 11th of August 2011

2
replies
Jerks on Pull Off
Thursday 11th of August 2011

4
replies
Rattle from rear of car
Wednesday 10th of August 2011

4
replies
Changing down gears
Sunday 7th of August 2011

1
reply
Transmission problem
Thursday 4th of August 2011

3
replies
C.v.t transmission fault
Thursday 4th of August 2011



1
reply
Fan running
Saturday 30th of July 2011

1
reply
Rear seat will not fold down
Sunday 17th of July 2011


3
replies
Engine wont rev
Monday 11th of July 2011


2
replies
Misfiring at low revs
Tuesday 5th of July 2011

10
replies
Engine misfiring
Monday 4th of July 2011

2
replies
Driver electric window not opening
Monday 27th of June 2011

1
reply
Petrol making swirling noise
Saturday 25th of June 2011

1
reply
Air con recharge
Wednesday 22nd of June 2011

3
replies
Air-Con
Wednesday 22nd of June 2011

1
reply
Loss of acceleration above 70mph
Tuesday 21st of June 2011

1
reply
Engine cuts out
Wednesday 15th of June 2011


2
replies
Key fob i put new batt in still not working
Friday 10th of June 2011

2
replies
Radio on when car is off!
Monday 6th of June 2011

2
replies
Timing belt or chain
Friday 3rd of June 2011

2
replies
Is Airbag light on an MOT failure?
Tuesday 31st of May 2011

1
reply
Starts but cuts out unless you keep revs up
Saturday 28th of May 2011

1
reply
Transmission power train cuts out
Saturday 28th of May 2011

1
reply
Speedometer cutting out
Thursday 26th of May 2011


2
replies
Transmittion system
Sunday 22nd of May 2011

1
reply
Heater runs hot
Friday 20th of May 2011

1
reply
Revs hunting
Saturday 7th of May 2011

2
replies
Can't open engine compartment lid
Friday 6th of May 2011

4
replies
Starting & idling problem
Friday 29th of April 2011

4
replies
Revving / fuses
Tuesday 26th of April 2011

2
replies
Poor fuel consumption
Tuesday 26th of April 2011


1
reply
Drive belt jumping pulley's (Fan belt)
Tuesday 19th of April 2011

1
reply
Brake
Tuesday 19th of April 2011

2
replies
Engine/ transmission noise
Thursday 31st of March 2011


2
replies
Rear brake light flashes when using same indicator
Monday 28th of February 2011

9
replies
Injector seal gone is this costly.
Friday 25th of February 2011

1
reply
Car is running at 2000 revs
Wednesday 23rd of February 2011

3
replies
Heater
Sunday 13th of February 2011

2
replies
Problem with heating system
Tuesday 8th of February 2011




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?