Ford Fiesta Problems - Page 10

List of owners' problems with the Ford Fiesta

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest Fiesta Problems

1
reply
Steering
Friday 29th of May 2009

2
replies
Intermitant Starting Fault
Tuesday 19th of May 2009


3
replies
Juddering
Sunday 17th of May 2009

3
replies
Heater inconsistent
Saturday 16th of May 2009

3
replies
Engine Revs too high
Wednesday 13th of May 2009

2
replies
First start up
Tuesday 12th of May 2009

1
reply
HOW DO YOU CHANGE WINDOW TRIM.
Wednesday 6th of May 2009

4
replies
Engine
Monday 27th of April 2009

3
replies
Not starting
Thursday 23rd of April 2009

1
reply
Ignition problem
Monday 20th of April 2009

1
reply
Stalling when cold
Thursday 16th of April 2009

1
reply
Problems with air conditioner when turn on
Wednesday 15th of April 2009

0
replies
Leaking water oil
Wednesday 15th of April 2009

2
replies
Whirring/grinding sound
Saturday 11th of April 2009

1
reply
Dashboard electrics not working
Friday 10th of April 2009

4
replies
Back seat release stuck
Wednesday 8th of April 2009

4
replies
Rev Hunting, Stalling when driving!! Please help
Friday 3rd of April 2009

4
replies
Creeking noise
Thursday 2nd of April 2009

1
reply
Accelerator jammed, please help!
Saturday 28th of March 2009

5
replies
Wont start
Thursday 26th of March 2009

2
replies
Brakes discs keep warping
Monday 23rd of March 2009

1
reply
Wont start
Monday 16th of March 2009

2
replies
Rev counter goes up but speed does not
Friday 13th of March 2009



2
replies
Starting problem (kno1 knows WHY though)
Tuesday 10th of March 2009


1
reply
How to change the ford fiesta front wheel
Saturday 28th of February 2009

0
replies
Will not turn over when hot
Thursday 26th of February 2009

1
reply
Brakes making a grinding noise
Thursday 26th of February 2009

1
reply
Car doesn`t always start
Wednesday 25th of February 2009

1
reply
No power to glow plugs
Thursday 19th of February 2009

3
replies
Vibration on break pedle at low speed
Wednesday 18th of February 2009

3
replies
Heaters blowing cold air
Saturday 7th of February 2009

3
replies
Starting up problems
Wednesday 28th of January 2009

2
replies
White smoke on starting
Monday 26th of January 2009

4
replies
Service light!!
Sunday 25th of January 2009

4
replies
Heaters blowing cold air only!
Friday 9th of January 2009

1
reply
Frozen Engine?
Tuesday 6th of January 2009

1
reply
Lack of grip
Tuesday 6th of January 2009



2
replies
Engine Management Light
Friday 19th of December 2008

1
reply
Overheating
Sunday 14th of December 2008

1
reply
High revvs when changing gear
Thursday 11th of December 2008

1
reply
Temperature gauge / Airbag light
Thursday 11th of December 2008

1
reply
Cold heater ((, mastertech )) spot on
Saturday 6th of December 2008

2
replies
Heater blowing cold
Monday 1st of December 2008

1
reply
Wont Start
Monday 1st of December 2008

2
replies
Iregular engine running
Sunday 30th of November 2008




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?