Citroen Xsara Picasso Problems - Page 8

List of owners' problems with the Citroen Xsara Picasso

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest Xsara Picasso Problems

0
replies
Headlight adjuster motor will not align
Friday 9th of December 2011

1
reply
Left indicator keeps flashing
Friday 2nd of December 2011


1
reply
Dashboard readout
Monday 28th of November 2011


2
replies
Little spaner
Friday 25th of November 2011

1
reply
Lost compression from Cylinder 4
Monday 21st of November 2011

1
reply
Brake not working
Saturday 19th of November 2011

1
reply
Wont start.
Friday 18th of November 2011

1
reply
Heater
Wednesday 16th of November 2011

1
reply
Lose of power
Sunday 13th of November 2011

1
reply
Steering wheel vibration
Tuesday 8th of November 2011

1
reply
Stereo code
Monday 31st of October 2011

1
reply
Petrol computer gauge
Sunday 30th of October 2011

1
reply
Part dash board not lit up and no brake lights
Sunday 30th of October 2011

1
reply
Dashboard Warning
Tuesday 25th of October 2011

1
reply
Where is the heater blower resistor located
Monday 17th of October 2011

1
reply
Indicatingwhen lights on
Saturday 15th of October 2011


1
reply
Whiningfromthepulley/cambelt side of the engine
Monday 10th of October 2011

1
reply
Speedo working intermittently
Tuesday 4th of October 2011

2
replies
Rear washwipe working when reverse is engaged
Monday 3rd of October 2011

0
replies
Side lights fuse
Sunday 25th of September 2011

1
reply
Side lights
Monday 19th of September 2011

1
reply
Day running lights
Saturday 17th of September 2011


2
replies
Overheating reading on dash
Friday 16th of September 2011

5
replies
Battery Drain - Its a toughie for you
Sunday 11th of September 2011

3
replies
Rear fog lamp warning comes on when footbrake applied
Tuesday 6th of September 2011

1
reply
Citroen Picasso water system
Friday 2nd of September 2011

1
reply
Where's the horn and cooling fan fuse?
Tuesday 30th of August 2011

1
reply
Washers not working
Friday 26th of August 2011

1
reply
Lights& central locking
Wednesday 24th of August 2011

3
replies
Indicators faulty
Wednesday 24th of August 2011

1
reply
Boot keeps opening on its own
Sunday 21st of August 2011

3
replies
Clonking/ rumbling from under car
Thursday 18th of August 2011

1
reply
Erratic idling/purging on tick over
Thursday 18th of August 2011

1
reply
Slight intermitent misfire.
Saturday 6th of August 2011


1
reply
Oil pressure low
Wednesday 3rd of August 2011

2
replies
Fuel leak
Sunday 31st of July 2011

2
replies
Clutch pedal
Wednesday 27th of July 2011

5
replies
Heater Blower on Full all the time
Thursday 21st of July 2011

3
replies
Fuse f15 blowing
Monday 11th of July 2011

4
replies
Gear selecter cable keeps popping linkage
Monday 11th of July 2011

0
replies
Need to change whole lock an barrel but carnt
Saturday 9th of July 2011

5
replies
Loosing coolant
Monday 4th of July 2011

3
replies
Engine Not Running Right
Thursday 30th of June 2011

3
replies
Auto air con/fan not working at all
Wednesday 29th of June 2011

1
reply
Alarm not responding
Tuesday 28th of June 2011

2
replies
Not starting in morning
Monday 27th of June 2011




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?