Citroen Xsara Picasso Problems - Page 6

List of owners' problems with the Citroen Xsara Picasso

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest Xsara Picasso Problems

7
replies
Really low mpg help please
Thursday 10th of January 2013

2
replies
Engine Fault
Thursday 10th of January 2013



1
reply
Blower and air con switch not working
Tuesday 8th of January 2013

1
reply
Central Locking problem
Sunday 30th of December 2012

3
replies
Main Beam not working
Sunday 30th of December 2012

1
reply
Stuttering in the wet
Sunday 30th of December 2012

3
replies
Engine Fault
Friday 28th of December 2012

2
replies
Second speed digit not displaying correctly!
Thursday 27th of December 2012

2
replies
Engine temperature
Friday 21st of December 2012

5
replies
Flat battery in cold weather. wont turn over the engine
Thursday 20th of December 2012

1
reply
Wont start
Monday 17th of December 2012

3
replies
Heater blower and washers not working
Wednesday 12th of December 2012

2
replies
Reverse lights not working bulbs ok ???
Wednesday 5th of December 2012

3
replies
Dead display
Tuesday 4th of December 2012

5
replies
Cold weather starting
Monday 3rd of December 2012

2
replies
All the electrics have gone
Thursday 29th of November 2012

2
replies
No Sound Radio
Thursday 22nd of November 2012

1
reply
Demister not working
Wednesday 14th of November 2012

0
replies
Digital Display
Tuesday 13th of November 2012

4
replies
Heater blower resistors. where are they located?
Saturday 10th of November 2012

2
replies
Right Indicator Speed Up.
Sunday 28th of October 2012


1
reply
Grinding noise from under the car from cold
Sunday 14th of October 2012

2
replies
No power and car stop
Sunday 14th of October 2012

2
replies
Loud whirring noise when turning
Thursday 11th of October 2012

1
reply
Central Locking and Rear Wiper
Wednesday 10th of October 2012

1
reply
Blades
Saturday 22nd of September 2012

1
reply
Brake's are solid in the morning
Friday 21st of September 2012

1
reply
Need to take inside door panel off
Sunday 16th of September 2012

0
replies
Low oil pressure stop
Friday 17th of August 2012

0
replies
Engine Fault indicator
Thursday 16th of August 2012

3
replies
Wont accelerate
Tuesday 14th of August 2012


1
reply
Car cutting out
Thursday 9th of August 2012

1
reply
Interior fan not working
Monday 30th of July 2012

1
reply
Outside air temp
Wednesday 25th of July 2012

3
replies
Fuil injector
Thursday 19th of July 2012

0
replies
Ratteling gear linkage from gearbox
Monday 16th of July 2012

1
reply
Engine fail
Sunday 15th of July 2012

5
replies
Engine fault
Tuesday 10th of July 2012

1
reply
Gears
Sunday 8th of July 2012

2
replies
Central locking
Wednesday 27th of June 2012

1
reply
Tail and fog lights not working
Tuesday 26th of June 2012

0
replies
BSI location
Wednesday 20th of June 2012

4
replies
Jingling noises
Wednesday 20th of June 2012


0
replies
Trouble starting
Monday 11th of June 2012


3
replies
Intermitent stalling
Sunday 27th of May 2012




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?