Citroen Xsara Picasso Problems - Page 11

List of owners' problems with the Citroen Xsara Picasso

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest Xsara Picasso Problems




5
replies
Radio won't turn off, no radio display
Thursday 9th of September 2010

3
replies
Rear wiper problem
Friday 3rd of September 2010

4
replies
Losing power
Monday 30th of August 2010

3
replies
Radio Dead
Wednesday 25th of August 2010

3
replies
Low Oil Warning When cornering
Saturday 21st of August 2010

9
replies
Keeps cutting out
Friday 23rd of July 2010

6
replies
Dipped Headlamps not working
Tuesday 20th of July 2010

4
replies
Cannot get gears
Sunday 18th of July 2010

1
reply
Headlight bulbs keep blowing
Saturday 17th of July 2010

0
replies
Warning symbol on the digital display panel
Monday 12th of July 2010

1
reply
Climate control
Monday 12th of July 2010

2
replies
Fuel gauge
Saturday 10th of July 2010

1
reply
Spair parts needed
Friday 9th of July 2010

4
replies
Faulty instrument display lighting
Friday 9th of July 2010

3
replies
OVERHEATING TEMP GAUGE
Monday 5th of July 2010

7
replies
Faulty fuel level indicator
Tuesday 29th of June 2010

3
replies
Lights
Sunday 27th of June 2010

1
reply
Non start
Friday 14th of May 2010

1
reply
Central locking fault
Wednesday 5th of May 2010

1
reply
WON'T START
Friday 9th of April 2010

2
replies
Dash K light on
Thursday 8th of April 2010

6
replies
Clanking in low gear
Wednesday 7th of April 2010

2
replies
Car not starting
Wednesday 31st of March 2010

2
replies
STOP - Oil Pressure Low
Monday 29th of March 2010

3
replies
Brake lights not working
Friday 26th of March 2010

2
replies
Boot wont open
Sunday 21st of March 2010

1
reply
Climate control blower will not switch off
Sunday 7th of March 2010

3
replies
Linstrument
Tuesday 2nd of March 2010

1
reply
Horn goes off randomly
Tuesday 26th of January 2010

1
reply
Heater not working
Saturday 2nd of January 2010

1
reply
Whining noise coming from under the bonet
Thursday 31st of December 2009

1
reply
Car no accelerating prop
Friday 4th of December 2009

1
reply
Wont start
Sunday 4th of October 2009

1
reply
No power
Saturday 19th of September 2009

1
reply
Racing engine
Tuesday 8th of September 2009

5
replies
Temperature gauge
Saturday 18th of July 2009

2
replies
Petrol smell in car
Friday 17th of July 2009

1
reply
Car not starting
Monday 8th of June 2009

1
reply
Engine revs up
Sunday 3rd of May 2009

1
reply
Heater blower not working
Thursday 13th of November 2008


1
reply
Petrol smell
Tuesday 23rd of September 2008

0
replies
Demister button not lighting up
Wednesday 17th of September 2008

1
reply
Indicater
Monday 24th of March 2008




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?