Citroen Xsara Picasso Problems - Page 10

List of owners' problems with the Citroen Xsara Picasso

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest Xsara Picasso Problems

3
replies
Fuel gauge fault
Tuesday 1st of March 2011

1
reply
Suspension problems
Tuesday 1st of March 2011




4
replies
Indicator light not working
Friday 25th of February 2011

2
replies
Scraping noise when ticking over
Monday 14th of February 2011

2
replies
Temperature gauge not reading
Tuesday 8th of February 2011

6
replies
Nothing on dash lights up and car won't start
Tuesday 1st of February 2011

8
replies
Water getting in behind drivers seat in he parcel well
Tuesday 1st of February 2011

1
reply
Power steering
Monday 31st of January 2011

1
reply
Reverse gear
Monday 31st of January 2011

4
replies
Gear change slow
Sunday 30th of January 2011

2
replies
Loud noise developed around belts area,plus smell
Monday 24th of January 2011

1
reply
Clutch cable comes off pedal!!
Monday 24th of January 2011

3
replies
STOP ENGINE TEMPERATURE
Saturday 22nd of January 2011

1
reply
Air Bag warning light
Friday 14th of January 2011

2
replies
Air vent switch not working on low setting
Friday 14th of January 2011

2
replies
Heater and fan not working
Monday 3rd of January 2011

3
replies
screen wash not working
Monday 3rd of January 2011

2
replies
Air temperature display
Wednesday 22nd of December 2010

2
replies
Automatic window wipers off?
Wednesday 15th of December 2010

2
replies
Engine running rough
Wednesday 15th of December 2010

1
reply
Windscreen codensating badly inside
Friday 10th of December 2010

1
reply
Wont start
Wednesday 8th of December 2010

1
reply
STOP LOW OIL PRESSURE
Tuesday 7th of December 2010

1
reply
Dash lights out
Tuesday 7th of December 2010

6
replies
Water
Monday 6th of December 2010

3
replies
Central locking not working off key fob
Saturday 4th of December 2010

3
replies
Driver window
Thursday 2nd of December 2010

0
replies
Rear suspension stops worn
Sunday 28th of November 2010

2
replies
Exhaust fumes through air vents,
Saturday 27th of November 2010

2
replies
De-mister will not turn off
Wednesday 17th of November 2010

3
replies
Wipers and washers not working
Tuesday 16th of November 2010

4
replies
Clutch vibrates
Monday 15th of November 2010

1
reply
Front wipers & washers stopped working
Sunday 14th of November 2010

3
replies
Clutch pedal sticks sometimes
Saturday 6th of November 2010

2
replies
Digital Display not illuminated
Thursday 4th of November 2010

0
replies
Front wipers won't stop!
Wednesday 3rd of November 2010

1
reply
Drivers door wont open
Tuesday 26th of October 2010

1
reply
Brake lights
Saturday 23rd of October 2010

1
reply
Brakes not working
Saturday 16th of October 2010

2
replies
Top up water level
Tuesday 5th of October 2010

1
reply
Keys dont work manually
Wednesday 29th of September 2010

3
replies
Smoking exhaust
Wednesday 29th of September 2010

1
reply
Bulbs for digital dashboards how do you get them in
Monday 27th of September 2010

4
replies
Speedo not visible
Monday 27th of September 2010

1
reply
Rear fog lights not working
Monday 27th of September 2010

1
reply
Exhaust smoke
Sunday 26th of September 2010

1
reply
Gearbox auto
Thursday 23rd of September 2010

2
replies
Jumping out of gear
Saturday 18th of September 2010




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?