AutoInsider Logo

Mitsubishi Shogun Problems

List of owners' problems with the Mitsubishi Shogun

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest Shogun Problems

0
replies
Auto gear box
Friday 27th of March 2015

1
reply
Tail gate door
Sunday 1st of March 2015



1
reply
headlight bulb
Monday 2nd of February 2015

3
replies
Reversing lights
Tuesday 2nd of December 2014

1
reply
Power loss
Tuesday 25th of November 2014

1
reply
Intermittent starting
Friday 21st of November 2014

3
replies
Engine suddenly very noisy
Saturday 10th of May 2014

1
reply
Can't select four wheel drive
Saturday 17th of August 2013

1
reply
Running gear
Wednesday 19th of June 2013

2
replies
Hot and cold
Tuesday 4th of June 2013

1
reply
Jeap kangarooing after new turbo fitted
Tuesday 30th of April 2013

1
reply
Front diff solenoid needs replacing
Thursday 28th of March 2013

1
reply
Stalling at junctions
Monday 25th of March 2013


2
replies
Cylinder head gasket blowing 3 times now.
Monday 21st of January 2013

3
replies
High revs on cold start
Saturday 12th of January 2013

2
replies
Knocking when changing gear
Monday 31st of December 2012

1
reply
Gearbox
Saturday 24th of November 2012

3
replies
How many hours labour to change a gearbox
Tuesday 13th of November 2012




1
reply
Stalls when stopping
Saturday 31st of March 2012

4
replies
White smoke
Saturday 10th of March 2012

1
reply
Automatic gear box slipping
Thursday 23rd of February 2012

1
reply
Rear door lock
Saturday 3rd of December 2011

1
reply
Location of engine ecu
Saturday 16th of July 2011

3
replies
It keeps stalling
Monday 11th of July 2011


1
reply
Flashing differential light
Thursday 12th of May 2011

1
reply
HANDBREAK CODES
Sunday 24th of April 2011

2
replies
Auto gearbox slow
Friday 11th of February 2011

2
replies
Lacking power
Thursday 27th of January 2011

4
replies
Sensor
Tuesday 25th of January 2011

2
replies
Cold starting system not powering glow plugs
Wednesday 31st of March 2010

2
replies
Turning over but not starting
Sunday 17th of January 2010

2
replies
Missing under load
Monday 14th of December 2009

3
replies
Glow plugs inoperational
Tuesday 22nd of September 2009

2
replies
Won't rev
Monday 13th of July 2009

0
replies
Loss of power
Saturday 2nd of May 2009

6
replies
Loss of power
Thursday 22nd of January 2009




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Twitter Icon Facebook Icon Google G+ Icon

Car Problems

Can you use a spanner?
Run an Auto Business?