Ford Escort Problems

List of owners' problems with the Ford Escort

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest Escort Problems

0
replies
Alarm unit pinouts
Monday 13th of August 2012



1
reply
Hiccuping loss of power misfiring
Friday 6th of April 2012

2
replies
Clutch
Friday 3rd of February 2012

3
replies
Drumming
Sunday 29th of January 2012

1
reply
Eratic idle
Sunday 15th of January 2012


1
reply
Tapping in engine
Thursday 29th of December 2011


2
replies
Loss of power rattling undernieth but looks ok ???
Monday 26th of December 2011

2
replies
Air bag light
Friday 23rd of December 2011

3
replies
Starting
Sunday 11th of December 2011

1
reply
Does not idle
Friday 2nd of December 2011

3
replies
Glow plug light flashes, its a petrol engine
Tuesday 15th of November 2011

1
reply
Gauges temperature and fuel tank
Thursday 20th of October 2011

2
replies
High revs.. on starting from cold
Monday 17th of October 2011

2
replies
Smoking and losing water
Saturday 8th of October 2011


1
reply
WHERE IS FUSE FOR HAZARD LIGHTS LOCATED
Friday 30th of September 2011

5
replies
Non charging battery
Monday 19th of September 2011


1
reply
Grinding noise
Monday 15th of August 2011

3
replies
Cooling fan not working
Saturday 13th of August 2011

2
replies
Indicator problem/hazard lights
Monday 8th of August 2011

1
reply
Engine management light
Monday 8th of August 2011

1
reply
Emmisions
Monday 8th of August 2011

1
reply
Pulling back when accelirating
Monday 25th of July 2011

3
replies
Dashboard lights for lights not working
Friday 3rd of June 2011

1
reply
Engine trying to stall on braking
Thursday 26th of May 2011

3
replies
Juddering when setting off
Thursday 14th of April 2011

1
reply
Taking rear seat out of car
Wednesday 9th of March 2011

2
replies
Rubbing noise
Monday 28th of February 2011

4
replies
Severe vibration from front of car
Tuesday 8th of February 2011

4
replies
Alternator
Saturday 5th of February 2011

2
replies
Over revving
Monday 3rd of January 2011

3
replies
Dip - Dim Relay - how to get to?
Monday 27th of December 2010

1
reply
Hot air heater not working, engine overheating
Monday 6th of December 2010

1
reply
Parasitic drain
Sunday 5th of December 2010


1
reply
Engine revs on its on sometimes
Wednesday 1st of December 2010

4
replies
Knocking sound from rear offside
Friday 5th of November 2010


1
reply
Stumbling and high revs.
Wednesday 4th of August 2010


2
replies
Smoke on start up, not while driving!
Monday 26th of July 2010

4
replies
Car not starting up
Thursday 15th of July 2010

4
replies
Dashboard Dials
Wednesday 10th of March 2010

1
reply
Fitting near side cv joint
Monday 8th of March 2010

1
reply
Removal of power steeing rack
Sunday 7th of March 2010

2
replies
ENGINE KEEPS CUTTING OUT
Thursday 4th of March 2010




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?