Rover CityRover Problems

List of owners' problems with the Rover CityRover

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest CityRover Problems

1
reply
Smell of petrol in car
Saturday 19th of September 2015

0
replies
Petrol Exhaust smells in car
Thursday 27th of August 2015


0
replies
Oddometer
Wednesday 28th of January 2015



1
reply
Car struggling to accelerate
Saturday 7th of June 2014

1
reply
Power steering has stopped
Sunday 2nd of March 2014

1
reply
Cut out completely while running
Sunday 24th of November 2013

2
replies
Digital Odometer not working
Saturday 23rd of November 2013


1
reply
Roof aerial
Tuesday 27th of August 2013

2
replies
Misfire
Friday 23rd of August 2013

1
reply
NOISY ENGINE
Sunday 24th of March 2013

1
reply
Car wont unlock with key fob, nor will it start
Monday 18th of February 2013

2
replies
Engine light on
Saturday 16th of February 2013

3
replies
Head Gasket
Sunday 13th of January 2013

2
replies
Fuel problem
Sunday 23rd of December 2012

1
reply
Fuel consumption
Wednesday 19th of December 2012


0
replies
Can't find the ECU!
Wednesday 7th of March 2012

2
replies
Steering wheel/wheel squeaking
Friday 24th of February 2012

1
reply
Gear stick shaking , srs light on, and petrol light on
Wednesday 8th of February 2012

4
replies
Brake lights
Sunday 20th of November 2011

1
reply
Heater not working
Saturday 15th of October 2011

4
replies
Headlights, sidelights not working.
Thursday 15th of September 2011

3
replies
Engine won't start
Thursday 8th of September 2011

0
replies
Speedo not working
Sunday 19th of June 2011

1
reply
Near side lights blowing fuses
Sunday 17th of April 2011

1
reply
Coilpack Failier
Thursday 17th of February 2011

1
reply
Over revving
Wednesday 2nd of February 2011


1
reply
Sensor
Monday 8th of November 2010

2
replies
Sensors
Saturday 6th of November 2010

0
replies
Still missing
Friday 29th of October 2010

2
replies
Heater
Monday 11th of October 2010

3
replies
Still missing
Thursday 7th of October 2010

2
replies
Cambelt sensor
Saturday 2nd of October 2010

2
replies
Cambelt sensor
Saturday 2nd of October 2010

2
replies
Engine keeps cutting out
Sunday 26th of September 2010

1
reply
Fuel filter
Friday 24th of September 2010


7
replies
Engine splutters and sometimes cuts out
Friday 10th of September 2010




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?