Rover 75 Problems

List of owners' problems with the Rover 75

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest 75 Problems

1
reply
Flasher telltail lights fault
Friday 1st of September 2017

0
replies
Coolant fan
Wednesday 30th of August 2017


2
replies
Reverse gear
Tuesday 14th of March 2017

1
reply
Over heating fan
Wednesday 15th of July 2015

6
replies
Over heating
Sunday 31st of May 2015

7
replies
Water floods into engine
Thursday 24th of October 2013

3
replies
Cooling system,radiator fan
Thursday 22nd of August 2013

3
replies
Judder
Thursday 25th of July 2013

6
replies
Power drainage
Wednesday 24th of July 2013

2
replies
Can't open passenger doors or boot.
Saturday 20th of July 2013

1
reply
Reverse gear (auto box)
Monday 1st of July 2013

1
reply
Jumping into gear at low gear
Tuesday 14th of May 2013

1
reply
Fuel pump in tank
Monday 8th of April 2013

1
reply
Engine
Sunday 7th of April 2013


6
replies
Won't start
Monday 1st of April 2013

1
reply
Cutting out for no apparent reason.
Thursday 31st of January 2013

1
reply
Clutch Problem
Wednesday 26th of December 2012

2
replies
When driving car seems to lose power
Monday 24th of December 2012



1
reply
Hot days and slow moving traffic.
Saturday 29th of September 2012

5
replies
Battery power draining ***help!***
Thursday 9th of August 2012

1
reply
Stiff clutch pedal
Friday 6th of July 2012

0
replies
Cold start cutting out
Friday 11th of May 2012

1
reply
Bonnet release mechanism wont release
Wednesday 25th of April 2012

0
replies
Tie rods
Wednesday 18th of April 2012

1
reply
Tailgate lock not holding tailgate shut
Saturday 10th of March 2012

1
reply
Ecus?
Saturday 3rd of March 2012

1
reply
Abs light on and revs up and down when idle
Thursday 23rd of February 2012

3
replies
Draining power from battery
Wednesday 4th of January 2012

1
reply
Automatic gear box
Tuesday 3rd of January 2012

3
replies
Smoking
Friday 23rd of December 2011

1
reply
Heater not always comes on
Wednesday 14th of December 2011

1
reply
Smokey egzausht and smell oil
Friday 11th of November 2011

1
reply
Spluttering cutting out black smoke
Wednesday 26th of October 2011

1
reply
Seperating clutch hydraulic components!
Friday 30th of September 2011

1
reply
Milometer stuck on 999999
Monday 29th of August 2011

1
reply
Fuel feed problem
Sunday 10th of July 2011

1
reply
Noise when turns the steering wheel
Friday 1st of July 2011

2
replies
Reversing sensor
Friday 17th of June 2011

1
reply
Speedo not working
Monday 16th of May 2011

1
reply
Smoking bad
Saturday 14th of May 2011

1
reply
Wipers
Wednesday 4th of May 2011

1
reply
Abs comes on under 30 mph
Saturday 23rd of April 2011

3
replies
Overheating
Wednesday 23rd of March 2011

3
replies
New pumps fitted but engine cuts out when driving
Friday 18th of March 2011

1
reply
Blocked Screen Washer
Thursday 3rd of March 2011

2
replies
Wipers windows and radio
Friday 25th of February 2011

5
replies
Tyre wear
Friday 18th of February 2011




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?