Rover 200 Problems

List of owners' problems with the Rover 200

Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

The Latest 200 Problems

1
reply
Rough Idle
Thursday 21st of November 2013

1
reply
Engine Hunting/Misfire at Idle
Monday 28th of October 2013


1
reply
Cold starting problem
Saturday 23rd of February 2013

9
replies
Internal light does not come on
Tuesday 12th of February 2013

3
replies
Cold start
Friday 8th of February 2013

2
replies
Brakes.locking
Wednesday 2nd of January 2013

0
replies
Jerking/Coughing through the gears
Monday 11th of June 2012

3
replies
Battery drain
Wednesday 18th of April 2012

2
replies
Revs high even in neutral
Sunday 27th of November 2011

2
replies
Anti freeze/bleed radiator
Thursday 13th of October 2011

1
reply
Loss of power
Tuesday 6th of September 2011

3
replies
Leak through switch on Auto Transmission
Saturday 27th of August 2011

1
reply
Central locking not working
Monday 11th of April 2011

2
replies
I need help fast!!!please help
Tuesday 15th of March 2011


0
replies
Wipers
Monday 29th of November 2010

1
reply
Heating not working
Tuesday 16th of November 2010

2
replies
No turbo and engine management light
Tuesday 16th of November 2010

1
reply
No turbo and engine management light
Tuesday 16th of November 2010

1
reply
Engine stalls please help
Monday 18th of October 2010

1
reply
Please help
Sunday 10th of October 2010

4
replies
Please help
Thursday 7th of October 2010

3
replies
Engine; overheating and losing power
Thursday 7th of October 2010

3
replies
Cant selct any gears
Sunday 29th of August 2010

4
replies
Auto box
Thursday 19th of August 2010

1
reply
Stalling at junctions
Thursday 22nd of July 2010

3
replies
Lack of power
Thursday 15th of July 2010

2
replies
Washer fuse keeps blowing
Tuesday 29th of June 2010

4
replies
Losing water and very hot
Tuesday 22nd of June 2010

2
replies
Drive belt pulley
Tuesday 15th of June 2010

1
reply
Loosing power
Thursday 10th of June 2010

2
replies
Expansion tank water boiling
Thursday 29th of April 2010

5
replies
Non runner possable low compression
Monday 15th of February 2010

2
replies
Condensation
Monday 8th of February 2010

2
replies
Noise coming from the car
Tuesday 2nd of February 2010


1
reply
Engine almost over heats
Saturday 9th of January 2010

2
replies
Engine Pinking
Wednesday 30th of December 2009

2
replies
Head gasket gone twice in less then a year
Wednesday 18th of November 2009

1
reply
Engine won't drop below 1500 revs when braking
Thursday 5th of November 2009

2
replies
Cutting out when stationary and driving
Wednesday 28th of October 2009

1
reply
Brakes
Friday 25th of September 2009

1
reply
Intermittant engine problem
Tuesday 22nd of September 2009

3
replies
Water damage
Thursday 14th of May 2009

1
reply
Engine wont turn off
Sunday 19th of April 2009

1
reply
Speedo & Odometer Not Working
Sunday 22nd of February 2009

1
reply
Car starts but loses power and drains the battery
Tuesday 18th of November 2008

1
reply
Spoiler sizes
Wednesday 12th of November 2008

1
reply
Loss of power
Friday 7th of November 2008

2
replies
JUDDERING
Monday 13th of October 2008




Can't see a problem like yours?

Can't see a problem similar to what you are experiencing? post a new problem

Social Media

Twitter Icon Facebook Icon Google G+ Icon

Car Problems - can you help?


Run an Auto Business?